Issue with Xert ZWO file downloads

I’m trying to ride my workouts using Fulgaz with the Xert zwo file being downloaded from Xert and uploaded to Fulgaz. I’ve tried a number of workouts but once imported into Fulgaz the workout is blank. I’ve tried downloading some of the Xert workouts zwo files that are on “trainerday.com” and they work perfectly with Fulgaz. Is there something wrong with the Xert ZWO downloads?

1 Like

Hey @oldcyclist65,

Can you maybe PM me the ZWO from Xert (that doesn’t work) and one from trainerday (that does work)?

A quick look at the files might make it easy to find any differences in the exports. Since the files work perfectly in Zwift, it’s not necessarily anything wrong with what we’re exporting. Fulgaz might be parsing the files differently than Zwift.

What is different between now versus then?


Is it specific workouts or have you always used ZWO files from Trainer Day?
Is it only with Windows 10 as that thread implies?

Hi Scott,

I’ll pm you the 2 files. The Trainerday one is identified with me adding “Trainerday” to the title.

On the previous version of Fulgaz (v3) with my Apple TV the zwo file uploaded fine and rode as they should, but with the latest version of Fulgaz (v4) they no longer seem to work. The workout is blank and the tss is zero.

Hi Scott,

I’ve attempted to send you the two files but the system does not allow attachments. Only images appear to be allowed.

Did you also file a support request with Fulgaz?
Sounds like the latest version changed something in how ZWO files are read.

Why bother with the export steps when XM with RP overlay is so much easier? Plus a better experience IMO.

How does RP overlay work on Apple TV? Link to instructions?

I was commenting on how much better the overlay method is since you get the full benefits of XM and SMART workouts.
Unfortunately that combo is not possible with Apple TV unless Zwift adds native support for Xert –
Zwift Apple TV 4K - Support - Xert Community Forum (xertonline.com)

Still not working.

Hey George,

Send the ZWO file over the Fulgaz support and ask them what this issue is with it. We can then see if we can make any adjustments based on what they find.

1 Like

Will do Armando, thanks.

I’m still awaiting feedback from Fulgaz support but I’ve read a few posts over on the Fulgaz FB group that others have had the same problem and that it could be down to the number of leading/trailing zeros in the file.

Here’s one example…

Still curious why you would bother importing into Fulgaz when you can play the workout as designed using XM?

XM? What’s that?

Xert Mobile – iOS or Android.
I assume you want to run Fulgaz on your Apple TV as a “distraction” while you ride the Xert workout as designed. No need to export/import the workout to do that.

How would I connect to Fulgaz on the ATV though if it’s connected to my android phone via BT?

Haven’t used Fulgaz in awhile but when I did it was on my Windows 10 laptop while I ran XM on Android. All Fulgaz needs is power paired for the SIM to work, no trainer control.
Isn’t that possible with the Apple TV app?

Fulgaz on ATV needs BT connection which in this case is connected to my phone so no.

Don’t see how that is different than how I ran Fulgaz on Windows 10.
Fulgaz was connected to power meter on crank.
XM was connected to trainer, cadence, and HR.
Workout ran on XM while Fulgaz route displayed on laptop.
Are you trying to view all sensors on the Fulgaz screen?
What’s the BT connection to your phone for?

@ManofSteele

I’ve received a reply from Fulgaz…

" Klem Johnston (FulGaz)

Jan 27, 2021, 16:04 GMT+11

Hi George,

This is unfortunately a known issue with XERT workout files, we’re looking into it.

Thanks, Klem."