Trainer control connectivity just quit working - help?

I just got on my bike and suddenly I cannot establish the trainer control between the bike (Renpho AI Smart Bike) and the iOS XBC App. The other bike connectivity (cadence, power) is fine. I don’t have any other devices around at the moment to try with. Picture below of exactly what I see.

Prior to now, I was raging with Xert and loving it, doing SMART workouts in AUTO mode, having breakthroughs, making progress.

There’s nothing about my setup that has changed… except that I updated to iOS 15.0.2. I tried uninstalling and reinstalling the app, and I also tried from an iPad, mostly same result except I do see the trainer, greyed out, settings. Here is what that looked like.

I am one sad guy right now, can anyone help? Again it all worked great, until it didn’t. Thanks.

Edit: I am pretty committed to XERT and if a way around this is to get an ANT+ adapter for iPhone/iPad I’m open to that. Or perhaps simpler and cheaper just get an android device for this purpose. My research is telling me ANT+ is a trustier connection.

Similar issue reported in this thread in case it helps –

1 Like

Hey @ridgerider2 – thank you for making the connection. I think I have a connection now including trainer control after a very compete disconnect and reconnect starting with control.

I am still going to try the ANT+ approach when I can get my tablet (it is in another state right now).

Thank you so much!!!

Same problem here, but recommended workaround to pair the Trainer Control first doesn’t work for me because there’s no device found. Pairing Power source and Cadence works, but I’m unable to run workouts without Trainer control :woozy_face: I think problem arised after updating iOS app.

Xert EBC version 3.1
iOS 14.7.1
Tacx Fluxx S smart trainer

pairing via ANT+ with Windows PC without any problems
Also hadn’t the chance to test with other device via BT

Hi all, I have exact the same issue, but the workaround to disconnect all connections and start with setting up trainer control first does not work for me (Tacx Flux 2 + Xert EBC IoS 15.0.2). Not able to use ANT+. Will contact support.

We have found the issue and submitted an update to TestFlight and App Store. Just waiting to hear back from Apple! Hang tight!



Should be rolling out any minute.

1 Like

New version for ipad and iphone in app store

1 Like

Y’all are awesome – thank you very much! @ManofSteele @xertedbrain @Janole22

1 Like

Yes, also works here. Thank you @ManofSteele @xertedbrain , @Janole22 . !

1 Like