iOS AUTO mode

Ok, so first time trying a workout in Xert, and I was in AUTO mode (which I didn’t understand but I was already started), and the cadence I was having to maintain to hit the power targets got more and more ridiculous. I kept changing gears but then (I think) the app kept reducing the resistance on my trainer. I tried switching to other modes (ERG, then slope etc), but it didn’t solve the problem, or maybe it takes the app a few moments to reconfigure, and I didn’t leave it long enough. Anyways, my legs were spinning like crazy and it got to the point where I finally gave up and had to quit the workout, which feels like a complete waste of my time. Pretty frustrating.

And I’m not talking 80-100 rpms. The app was forcing me to maintain ridiculous levels like 120.


Brand/model trainer?
Which workout?
How much historical power data is loaded?
Is your fitness signature valid?


Are there errors in my Fitness Signature? – Xert (

Introducing Smart Workouts – Xert (

Saris H3
The Pretender 90

I uploaded 6 weeks of Zwift rides (about 4-5/week) and my calculated FTP matched Zwift. So I’m pretty sure my signature is valid?

Are you sure the App was set to Trainer Control? Which App were you using? Android, iOS, or Garmin?

1 Like

Your fitness signature in Xert is more than FTP (TP).
Did you review the article links?
Does your HIE fall into normal range of the PP chart?
Are there any BT (breakthrough) events noted in your Zwift data?

Pretender isn’t a mixed mode workout or SMART interval workout. It is a typical ERG workout other than the fact it’s based on MMP and LTP.
You should have been able to ride that in one gear if the Hammer was truly under trainer control.
Do you normally ride your H3 on the small ring in a middle gear for ERG workouts?
Is power paired to a separate meter? (powermatch enabled)

1 Like

iOS AUTO mode as per the thread title

Hi Ridge Rider,

My Xert fitness signature is higher by 5 points than my Zwift FTP.

Yes, I reviewed the article links. They told me nothing I hadn’t already read or know.
Where is this Peak Power chart you speak of?
Yes, I’ve had 7 Breakthroughs recorded in my 6 weeks of riding.
Normally I do workouts in slope mode at 2% and control my cadence with gearing. I find my current fitness finds me switching between the big and small ring, and switching between the middle fours cogs on my cassette.
No, my H3 is my only power meter.

Look, I’ll try again tomorrow, although not today. (That’s another thing… Xert is telling me I’m fresh, and I know that I am definitely not. In fact, I’m completely cooked and have plateaued in the last 10 days with my legs screaming at me. I’m coming off of virtually no fitness and have been pushing myself pretty hard for 6 weeks with one rest week in my 4th week. All my big breakthroughs have come after two or three days off.)

Anyways, thanks for your help. I’ll try again tomorrow or see if I can sort things out. I suspect when I start the workout in Slope 2% things will work fine.

Btw, thanks for replying guys, I really do appreciate it.

See if your HIE falls within range indicated in the PP chart in this article –
Are there errors in my Fitness Signature? – Xert (

Seven BTs in 6 weeks sounds like your signature is still settling in. Once dialed in BTs will get harder to achieve.
If you are not feeling fresh before a workout dial back the freshness feedback slider under Goals to reflect how you really feel.
If you need a recovery week you can dial down IR (improvement rate) then dial it back up when you’re ready.

When feeling fresh try the same workout in AUTO mode next time just to see if it works correctly.
I suggest small ring up front and a couple cogs up in the back for a mid range gear. IE, the sweet spot for riding a Hammer under trainer control in AUTO/ERG mode.

So I checked out the chart (thanks), and my peak power is way below my high intensity energy. Ie, it says PP is 600w and HIE 24. However, I suspect that is because most of my data has been garnered from 1 hour efforts where I was in Zone 5? (Zwift zones) the entire time, my heart rate totally maxed out, and so I have never put in any big sprint efforts. I am pretty certain I could put out much higher than 600w if I was fresh and attempted it. But I’m starting from such poor fitness, that my focus has just been building a base with those “races” and then some longer endurance rides. I’ll get to the sprint stuff eventually, but I think it will take a couple of more weeks before my legs and body catch up to the six weeks of load I’ve put them under. WTF is going on!?? my body is probably wondering.

What I meant was how is your trainer connected. 3 photos attached to show you what I mean.

This is how it should look on the settings page.
If it’s like this

Nothing is controlling your trainer but it can still operate in Auto. It just that the trainer will default to it standby resistance and you may have to pedal like a hamster to get the power and the resistance on the trainer will not track the power on the workout.

Hope I’ve explained myself properly

Pretty sure it looked like the first picture with one exception…

When connected the trainer I was given two options Hammer or Hammer FTMS. I had never come across this before (Zwift, RGT and Sufferfest just connected to the trainer without any difficulty). Do you know the difference, for instance, between your Zumo and Zumo FTMS?

I’ll confirm when I ride again how I’m connected. But I’m totally cooked and overtrained right now, I think, and need to give my body some time to catch up.

ALSO: I’m pretty sure Xert was controlling the trainer because the resistance did change. At first the resistance was reasonable, but by the time I gave up it had definitely backed off to the point I was pedalling like a hamster to meet the power targets.

FTMS is the Bluetooth industry standard for fitness equipment (like FE-C is the industry standard for ANT+), and what our app uses for trainer control. You should connect to the FTMS version of the Hammer.

Ok, maybe that was the problem. We’ll find out soon.

Just to follow up, I did Lucy In The Sky With Diamonds today. I started in AUTO mode on the small ring and somewhere in the middle of my cassette, maybe the fourth ring, and pretty soon I was having to pedal at 101 rpm, which for a 2 hour workout is ridiculous for me at 6’2". I’m all for spin-ups and cadence work, but 2 hours maintaining between 93 and 101 rpms ain’t my zone. So I switched to Slope mode at 2% and that was perfect, moving the range to 84-92 rpms between intervals.

Is Xert intentionally try to get you to pedal between 93 and 101, or is that just a quirk that’s different with different trainers? Or do alot of people find that range comfortable?

But anyways, the trainer is working fine. I’ll stick to slope mode. That’s what I used to use on Zwift.

Any chance someone can answer this question for me? :point_down:

Is Xert AUTO intentionally try to get you to pedal between 93 and 101, or is that just a quirk that’s different with different trainers? Or do alot of people find that range comfortable?

I would like to be able to use AUTO mode, but it’s completely useless to me if it forces me to ride at unsustainable cadences, and I can’t adjust it.


Auto mode would have these intervals in ERG mode I believe, in which case resistance adjusts to your cadence to maintain power. So you have (near enough) complete freedom to choose cadence for the power… the faster you pedal the lower the resistance and you’ll still be at the correct power. Were you at the right power? if you then slow down cadence, resistance increases after a few seconds to maintain power - have you tried that? Guess it can take some getting used to

If it’s definitely an AUTO issue, have you tried selecting ERG mode explicitly and does that behave as intended (per above)?


Seems odd your trainer would dictate a particular cadence for ERG. Did you try using a different gear to change the range?
Lucy in the Sky 120 can be done in AUTO or Slope mode (as noted in description). In AUTO the resistance should be normal ERG (90/85% LTP for Lucy). At that level power you should be able to pedal at whatever cadence you feel like doing including below or above your normal cadence.

You will notice some workouts are tagged with MIXEDMODE meaning the workout player will automatically switch modes depending how the interval is defined.
It appears you are accustomed to standard block chart training and prefer to perform intervals in slope/resistance mode. Nothing wrong with that, but the Xert app supports mixed mode, curvilinear, SMART (two types), and numerous options besides %FTP for intervals. Open one of the workouts in Workout Designer, click on any interval in the Power column, then view the dropdown selection to see all the options.

1 Like

I did try changing the gears but things just kept getting easier and easier. I think Wes has nailed what happened…

I’m used to doing intervals in slope, so every time I ramped up I was expecting to have to pedal faster, so I did, and then the trainer reduced resistance to compensate, and on and on, so every interval it kept reducing resistance over and over as I kept pedalling faster and faster… because I didn’t realize the trainer was trying to adjust the resistance to match my cadence to bring power up.


ERG (or in this case AUTO since the workout is all ERG) mode is the “switch OFF your brain and let the computer do all the thinking” mode :wink:
Maybe watch a movie next time and just move your legs at a comfortable cadence and everything will work out fine.