I'm using the "MPA and Power - Xert" on Garmin 1030 MPA always 1200

I am currently using the “MPA and Power - Xert” NOT “MPA & Power - Xert (old)” and the MPA always starts at 1200 but my max power is not 1200. In the Garmin IQ application on iOS it only shows login and seconds. Why can I not change that to my actual MPA. Am I not understanding something?

Don –

2 Likes

Not sure if this still applies or not –
Garmin Connect MPA & XSS Data Field Issues - Support - Xert Community Forum (xertonline.com)

Reference: How do I install and configure the Xert Garmin ConnectIQ Apps? – Xert (baronbiosys.com)

1 Like

You know I’ll give that a try. My Fat & Carbs data field didn’t work until I moved it to a different “space”. Maybe that “reboots” them with the new login information settings (ie. login, etc…). Thank you for the detailed lead.

I had no luck with the MPA and Power always reads 1200 on my Edge 530 I uninstalled and reinstalled it 3 or 4 times now.

Welcome to the wonderful world of Garmin Connect-a-doodle-dum. :slight_smile:

How to add, update and troubleshoot Xert apps/datafields on Garmin – Xert (baronbiosys.com)

1 Like

Simply switching profiles (i.e. indoors, outdoors, race, etc) forces all CIQ data fields on that profile to refresh the settings. So sometimes changing password (and clicking save/update) and then switching profile to something else and then back will force the data fields to update with the username/pass.

Hope you get it figured out!

1 Like

Be sure you check out the last article @ridgerider2 posted! Should hopefully walk you through getting your data fields installed and updated.

I finally got everything to work. It was a combination of Garmin Connect Sync, entering name and password on Garmin and Garmin Connect (syncing again), AND starting a ride (even though I didn’t go anywhere). Then just wait. Each one went from orange to green. It does take about 5 minutes. Hopefully it’s now good to go! I blame it more on the Clunky Garmin OS / Interface. XERT isn’t the only thing that seems to have a full meltdown on my 1030 at least once a month…

1 Like

Ok I got it going too I uninstalled each one then rebooted the Garmin and then connected to my laptop I only installed MPA and Power entered my username and password saved and resynced. Then powered up the Garmin put it in a data field then powered off and on again started a ride and waited it went from orange to green WOOHOO! Then just repeated each step and all four data field worked I will test them out Saturday on my ride if everything goes well this will be a real game changer for my outdoor rides.

Regards
Dave

1 Like

Correct. An activity needs to be active to trigger the data field to retrieve your fitness signature from the server. Now that you have it set up and working, should take less than 15s every time you start a new ride.

Glad to hear you got it working as well @davesans!

Currently my 1030 serves as a paper weight on my trainer desk. Works great!
XM on a Palm phone is all I have used for 2+ months now, but I am only riding indoors.

1 Like

Did you ever get it to work on you 530?
I am having zero luck on my 520.
I cannot get segment hunter to work either.
TTE seems to work, but I wonder if it is going by the default 1200 or my actual signature?

Hi Rob
Yes I did I had to reset my password then re enter it in Garmin express I did each field one at a time on the 530 so that I new it worked. When I connect my phone to the 530 and start the 530 it will update the fields with the current fitness sig it takes a few minutes but has worked every time since I did that. Hope this helps and let me know if you get it to work