XSS Buckets does not record

I have two problems with the new XSS Buckets data field. Using an Edge 530. Connect IQ shows version 6.0. I am sure that the settings are configured incl. username and password, and syncs to the device. Tested by changing the default XSS Low Target. Shows up on the Edge.

But it newer syncs the target data from the adaptive training advisor.

And worse, it does not record any data. It shows the PWR, but all L H and P XXS stays at zero. Even when the seperate XSS data field works.

Any ideas?

Regards,
Kaj

Have you tried a reinstall?

Yes, tried that now (reinstalled yesterday, tested today)

Still no change.

Regards,
Kaj

Now I reset my garmin Edge 530 and configured it again - including installing data fields.

Still no luck.

I hope it’s not because of the language of the device?

I also tried to add the datafield on my forerunner 255. Same result.

The dot at the upper left continues orange/black, and no data is recorded.

Hi. Please try the new version that should be pushed to the store later today. If for some reason that doesn’t work, please reach out to me. If you are on Facebook messenger, that works. I’ll work with you and figure out exactly what is causing this strange uncommon issue and we’ll get it sorted out. If Power is showing on optional Buckets Power Bar, and you’ve started the Activity, then XSS Actuals should be accumulating as you are riding. Let me know.

2 Likes

I came here looking for a solution to this exact issue. Tried installing on both a Garmin watch and head unit. It installs successfully, and I can manually update the target values but will not sync with Xert to pull the days values down. The Xert login setting in the app are saved without error. I have the standalone focus and XSS fields and those are able to sync, update, and respond accordingly to the ride output. For what it is worth, I’m facilitating via the iOS version of the ConnectIQ app. In the case of the “Buckets” the values are not responding/updating during the ride. Also, I have the 27 May version of the app installed and the behavior is the same as the previous version. The light indicator at the top blinks orange. Thanks!

I think the new version solved my problems. Have to do at longer test, but it syncs data and records data.

One strange thing I noticed: After it says "“UPDATED!” and the values are updated, the dot at the upper left turns green - but then after some time turns orange/black and the display shows “Server fetch X” - this time X was 4, but not sure thats the same value each time.

Thanks for the update!

The “Srv Fetch” was a debug pop up that will be removed in the next version, 6.4, coming out very soon. There are several code paths that can initiate a Server Fetch. I made some nice updates. If you have a radar, it’ll skew the top bars over so the radar icon won’t obscure the values. I’ve increased the pill size when displayed in larger fields (like 1/2 of an EDGE 1030). I’ve fixed the Estimated Ride Time Remaining in the XSS/hr pill (using a 20 min smoothed strain rate metric). And a few other things. You might notice I also write FIT Strings in the Garmin Activity file that let you know XSS totals and Difficulty for the ride.

image

2 Likes

Great app, thanks!

1 Like

How is it supposed to work when you start a second workout in a day? Say you have 100 XSS assigned a day and you complete them all. Then you start a second ride. Will the target still be 100 and you will start with 100 XSS? Or will you start with 0 XSS and a 0 XSS target? Or….?

I did this yesterday with a ride to work and then back again at the end of the day 2hours in total adding up to the 2 hours of riding that XERT was recommending. In the evening it gave me the same XSS target as for the morning ride. I noticed as this was also something that piqued my interest

The buckets data field will show the overall XSS recommendation for the day if you don’t have anything planned (or the XSS targets of your workout/activity, if you have one scheduled).

If you’ve already done a ride (maybe a commute or two) before your main “training” ride, you can select a workout that matches the XSS remaining and ‘Buckets’ should update to show those targets (even if you don’t explicitly follow that workout - hope that makes sense). Alternatively, you can use the data field settings to manually set your XSS targets.