Xert Workout Player on Garmin Edge 530 & Tacx Flux S

Hi, I’m new to Xert and have been doing some workouts with the Xert EBC app without issues. Earlier today I tried to do a workout using the Xert Workout Player on my garmin Edge 530 and Flux S smart trainer. I noticed that the smart trainer didn’t change the watts automatically during the workout the way it does while using the EBC app, so I had to manually shift gear to make the adjustments.
Do you know how I can make sure the garmin device communicates with the smart trainer so I don’t have to change gears manually?

View the workout details and description.
If MIXEDMODE is mentioned some intervals will show %slope in their definition.
That means Xert apps will switch from AUTO (ERG control) to Slope (gears/cadence).
This avoids spiral-of-death and trainer response issues especially for high intensity spikes with short RIBs (rest-in-between) and sprint efforts where the goal is to max out rather than hit a particular watt target.
To view some examples, visit the Workout Library and search for “mixed mode”.

Hi, I was doing one of those mixed mode workouts apparently. Via the app & bluetooth connection to my trainer, this works perfectly. Only with the garmin iq Xert Workout Player it doesn’t seem to work right now…

With the Garmin make sure you are using the Indoors profile with sensors connected under Garmin settings.
If signature sync with XO (xertonline.com) isn’t working, run Garmin Connect on your phone and verify setup there.
As you have no doubt noticed, there are many more features for running workouts on the EBC phone app.

Reference –
Installing the Xert Player for Connect IQ - YouTube