Xert Player Issues

Today Xert player on 1030 stopped being able to control Tacx Neo trainer. The power match doesn’t function and player freezes time to time. Tried deleting all data fields and reinstalling the player, however that did not helped. Spent 2 hours trying to resolve the issue instead of training. Can you please help me to resolve this issue?

So did on my 820. Everytime it freezed (about two times in a minute), in order to continue training, i solved tapping on the screen and click “reconnect” on the trainer menu while continuing to pedal. That was frustrating but was the only way not to waste my time.
Please give us feedback thank you

See my Xert CIQ Failure thread below it sounds similar.

Sometimes recycling the trainer (turn it off and on) can help put things back on track, especially if things have been working fine in the past. The CIQ environment is designed so that apps cannot communicate with each other. They run independently. You shouldn’t have to uninstall a datafield (ours or otherwise) to affect the workout player. Sometimes the 1030/820’s persist information on the device even though they have been “removed”. This can be part of the problem and relying on the Garmin removal/install can be problematic. Removing, rebooting, reinstalling can often help. We’ve made Garmin aware of these issues. Luckily the issues aren’t universal so there is something in your configuration that is causing the issue. If you manage to find something, please let us know. We’re continuing to investigate and see if there is anything we can discover. Thanks for your patience.

I have the same problem with my 520 Xert player…last update datafields broke Xert player

Hi Rober. Are you able to sideload this: https://www.dropbox.com/s/bjghhr9vjufhbbe/WorkoutApp.prg?dl=0 (remove the current Workout Player first) and let me know if it changes anything?

(I don’t think the apps did this, btw. Likely some other update. There’s nothing connected between the apps and the workout player).

I don’t update some other app,only update xert datafields

Ok. We pushed an update to the Workout Player. Try updating it and see if you still experience any issues.

Installed and reinstalled the update, rebooted device, reconnected. Done each a few times. No luck. Looks like the power on trainer disconnects each time xert starts because because when I exit the app it’s reconnects again.

Do you happen to have the trainer configured as a power meter in the Sensors menu on the unit?

Yes. That’s has worked for me before. I also tried connecting it as a trainer as well. Didn’t work.

You may want to switch activity profiles to one that doesn’t use the datafields before you start the player. Appears there may be a conflict in the CIQ system. Reported to Garmin.

I’ve deleted all the Xert data fields awhile ago to ensure they’re not interfering. Also reset my 1030 and reconnected all sensors. Reinstalled the player again. No results.

Saw your post on FB group about selecting NONE and reselecting trainer. That has worked for me. So far works fine with data fields installed and used in activity profile. I’ve turned on the player a few times and it was working right away.