Xert not syncing with strava rides

I normally use a Wahoo elemnt bolt, but I really wanted to try the xert mpa widget while out riding. So I went back over to the dark side and bought a second hand Garmin 520. Unfortunately the previous owner did not clear the unit, so when i connected it to my strava account I got all his rides since 2019.
After spending a few hours removing all his rides from my strava dashboard, I now have to sort out the Xert rides as this had also picked up all his rides.
I though the quickest way would be to delete all the activities and resync back a year or so.
So I have deleted all of my activities, and tried to resync, but nothing seems to happen. I can’t even just pick one activity and sync it.
I must be doing something wrong. but I can’t work out what
I’ve tried disconnecting my strava account and reconnecting it.

Do you mean syncing your Strava activities with Xert?

This took me a little time to work out, when I shifted from a trial account to a paid account & wanted to transfer more historical data through.
This might help…?

In Xert, go to the Sync>Strava link.
Select the date range & choose Custom Range - then choose the range you want to upload - start date in the left calendar, end date in the right calendar. Hit apply.
This should give you a list of activities. You then need to click the ‘tick all’ tick to the left of the activities at the top, which selects all of those activities, and then on the bottom right there is a red “sync” button.

Once you hit that, they should sync.
I assumed the sync would automatically happen, so was missing the fact I had to select the activites with the ticks & then hit sync myself to start the process. Once I worked that out it synced fine.

Hopefully that is the same issue you are having. If it is something different, then I’m all out of ideas :o)

Yes, I’ve done it loads of times before, but it just won’t work now

You probably need to reset your account but first I would file a support request with support@xertonline.com and explain your predicament.

I’ve contacted support but no reply yet,
I’ve tried resetting the account but still not syncing, i can’t even load a fit file manually, I drag and drop the file’ but there’s no way to continue.
anyone from Xert there? try to sync my last months Strava activities could you- let me know what I’m doing wrong
I’ve been using Xert since the end of 2019. Its never done this before

ok this is what i normally do- tick the rides

click the sync button-

I get this come up

but nothing more. no activities appear

anyone from xert out there to help me?. I was hoping to use it this weekend but without a fitness signature it wont work

cheers for fixing it. all working again

You are reaching the user-to-user community forum here which is loosely monitored by Xert.
It appears they have responded to your support request. :+1:
Should you have an issue with starting signature in the future you could use the Power Curve Calculator and enter 2-3 known values.