Xert Ios App appears to be broken after 4th February Update

I run Xert on an old iPad Mini which has been working flawlessly up until the last update on February 4th. After selecting the workout and pressing play the app just shuts down. I’ve switched on & off the iPad but still no joy. Its running IoS 9.3.5 which cannot be updated. Is anyone else having the same problems before I get in touch with support. #wishingautoupdateshadn’tnbeenenabled

Hi Cary,

Sorry for the troubles. We’ll look into it…

For now, start by performing a fresh install.

Will do. Didn’t think of that.

I’ve just reinstalled it and it is still switching off

Looking into this today!

I also seem to have encountered a bug:

When trying to filter the workouts via Workout duration, the keyboard or numpad does not show. So it is impossible to enter the time to filter by. Instead the current time is shown in the bottom left corner.

1 Like

I am experiencing the exact same issue, with an older iPad mini running the same iOS.


We’re working on it. Fix should be posted soon!

Thanks for your patience!


I am getting a “Connection Error.”

Kindly double-check that you’re signing in using username and not your email address!

1 Like

New app 2.2.8 on the App Store. Hopefully issues with ancient v9 iOS users :slight_smile: and workout filter have been fixed.


Ha Ha hope you mean the App is ancient and not the user :smiley:


Great, filter is fixed, thanks!