Xert EBC Android didn't record my HRR?


Just did a moderate 45-minute ride because I have a cold, and noticed halfway up Le Col D’Iseran that I couldn’t see my HRR. Swiped left to go back, checked settings and sensors and my Garmin Dual was listed, connected, with a full battery. Disconnected and reconnected mid-session but my heart rate didn’t show up.

What should I do differently?

Hi @rgarner - send a note to support for technical issues like this. Include screenshots, if possible.

Should make sure that the HR sensor icon is teal (indicating that the app is receiving data from your HRM).

1 Like

Thanks. It was teal, but a second ride recorded nothing. I’ve uploaded screenshots to support this time and what I did with having a phone running the stats and a maximised laptop session with a Norwegian video.

For anyone else with this problem:

@ManofSteele said he’d seen this on “other platforms”, so I went and checked with Strava and with Wahoo, and neither of those was getting a number either despite the Garmin Dual HRM being ostensibly connected.

Ok, I went to try and clear Bluetooth Cache, as this has solved the issue for many according to Reddit. Google greyed out the option in Android 13. The only option left is apparently to reset all my networks and bluetooth — losing all my paired devices and wifi networks. Ok. This is important to me. Deep breath. You can rebuild that stuff.

Reset, reboot phone, fire up Xert — I see a little “50” below the heart rate device. And on an activity, it works.

Painful, but not Xert’s problem. And shame on Google for removing that little bit of granular cache control.

So if you have this problem with a Garmin Dual HRM and Android, either a bluetooth cache clear for Android <13 or a painful network reset for Android >=13 should clear it.


Correct. I’ve seen this reported elsewhere (here). Strange that it tends to be the Garmin ‘HRM Dual’… I haven’t seen this issue with the HRM Pro or HRM Pro+ (yet?).

Glad that you were able to resolve the issue with your handy tech skills! I’ll keep this in mind if we have other users that are running into a similar issue.

The only thing I can cross-reference it against is that apparently there was a firmware update in late 2021 from 2.30 to 2.50 in which it was speculated that the format of the stream was changed subtly. I don’t necessarily agree that app makers needed to scramble to respond at app level but a subtle incompatibility with BLE stacks (resulting in occasional yet widely reported errors) on multiple platforms would probably not be out of the question. I also got the distinct impression while tech-speculating (techulating?) that Apple’s BLE stack was a lot nicer to work with than Google’s…

1 Like

Wow, thanks for sharing this. I ditched my android for xbc with Garmin dual HRM a few months ago because of this and have been using my spare Karoo1 instead.

I’ll give this fix a(nother) go and hopefully it works now!


1 Like