Xert EBC 3.1.8(32) and STAC Zero

The Trainer Control for STAC Zero no longer shows up. I recently updated to Xert version 3.1.8(32) and I feel this might be the cause.

This has been working previously. Please help. Thanks.

This shows that it’s visible as a Power Source. Trainer Control is now missing.

Is that the iOS beta version?
Join the Xert EBC beta - TestFlight - Apple
You can report problems directly to: support@xertonline.com

No. The version I’m using is from the App Store.
And I have also reached out via e-mail with the same.

It was working the last time I used this, about a week ago. I saw the new version in the morning and without too much thought allowed the upgrade. And here I am with an app that can see power meter on the trainer, but can’t control it.
I had a boring static erg mode ride instead! :pensive:

1 Like

In a pinch you can run the STAC Control Panel app, select Ride and adjust resistance or ERG values on-the-fly with slider controls. There is also some way to run workouts and load a default workout but I have never tried that.
I have been using EBC Beta with my Halcyon since November last year but with various Android devices, not iOS.
You might consider trying the iOS beta as that has the latest features for iPhone.

I just joined the TestFlight for iOS to try out the beta of Xert EBC. Unfortunately the production and beta are the same version number! Not surprisingly they show the same behavior. I sent feedback via TestFlight and hopefully it has more telemetry for figuring out what went wrong.

1 Like

Sorry, I didn’t realize the beta went to production release on 7 Oct.
I haven’t had any issues connecting my Halcyon with the Android app but I have had problems with the Halcyon that was only fixed by running the STAC Control Panel app.
Does the Tutorial option on that app work fine with your trainer?

1 Like

The STAC Control Panel app is no longer available.

The 4iiii version on ios is able to connect and command basics such as open all the way. So this means that the iPhone BLE to STAC Zero Halcyon still works.

And I think out of scope, but I’m able to control the Halcyon via a Garmin ForeRunner 945 watch.

I wish I was part of the beta program earlier

I’m open to other suggestions.

Sorry for the issue you’re having. We’re going to see what we can do to get you back and running again, either by finding a way to sort out your issue or perhaps provide a way for you to use the older version until we sort out the issue. Unfortunately, Apple does not provide a way to distribute older versions.

The app does now support the Cable ANT to BT converter from North Pole Engineering and your trainer should work with that since it supports ANT FE-C (how it works with your watch). If you happen to have one, the new firmware for it should allow our app to connect to ANT+ sensors and your trainer.

Thanks everyone for the suggestions.

I might be able to borrow an Android phone for a while.

All my kit supports BLE and I’m not inclined to purchase the dongle to allow the iPhone to connect to ANT+. However, I might be interested in something that will BLE to ANT+. I have a lot of older kit that only does BLE and it would be nice to be able to capture metrics on multiple devices. But that’s another topic!

And manual controls do work. It’s just not the same! I really do like the work out that mix it up. I tried straight up erg mode and I got so unmotivated in 30 minutes, I gave up!

If there’s anything I could do to help with testing, do please let me know. My $dayjob used to be software development and in a prior career was a QA for video games.

If you can’t borrow an Android phone you can probably pick one up at a smartphone repair shop for as little as $25. Or a friend may have an old one sitting in a box somewhere. :slight_smile:
All you need working is Wi-Fi and Bluetooth. No SIM.
I suggest Android 8.1 or higher.

As far as the 4iiii app goes I notice you can set Difficulty (default = 27%).
When I first got my Halcyon I did an experiment using this function on the STAC app…
You can actually perform a RAMP test by setting a fixed % with the gear of your choice (11, 12, or 13t with big ring) then use cadence to control the RAMP steps.
For example, start at 70 rpm, warm up, then step up 5 rpm every 1-2 minutes until failure.
It works because the Halycon increases resistance in relation to wheel speed.
You could use also this method to emulate a workout with variable watts. YMMV :smiley:

My issue is resolved.

The support team from Xert suggested stopping / disable / unpair all of the sensors. Try pairing the Trainer Control first.

This worked and the rest of sensors such as power meter, wheel speed, etc got paired as well.

Classic “have you tried turning it off and back on again?”

1 Like

Actually, it’s more a workaround. We’ll fix it in the next release so that there is no order dependency otherwise the same thing will happen to others.


I did not mean to make it sound easy or trivial. I certainly didn’t have the patience to try all the different combinations and I don’t have the insight on the complexity of the BLE stack.
I look forward to the future releases!