Xert App won't find sensors

Can anyone explain why my BLE and ANT+ sensors (Elite Qubo Digital Smart B+ / Polar H10 / Garmin cadence) will connect immediately to the Zwift App on my Google Pixel 3 (with Android 11 and ANT+ dongle), but not all to the Xert App? Actually the Polar H10 will. Sometimes.
Intuitively it seems to be an App issue, not a phone issue.

I stopped using an ANT+ dongle with my Pixel 2 almost a year ago when BLE code was updated in XM I’ve been connecting with BLE exclusively since that time (power, trainer control, HR, cadence).
As an experiment try removing the dongle, restart the phone, then start the app, change to activity, and see how quickly devices connect via BLE.
I don’t remember if there was an option to remove the ANT+ entries, but I no longer see them listed under Settings, Sensors.

Thanks for the suggestion, but no joy. Here’s the thing I’d like to understand: It’s an Elite Trainer. Elite’s myETraining App AND their Upgrado App can both see, and connect to, the ANT+ and BLE channels. Zwift can see and connect to, the BLE and ANT+ channels. My Garmin 945 connects to the ANT+ channel instantly. And when I go to the Bluetooth menu of the Pixel it identifies the trainer as a BT device, even though it won’t pair with it (I tried). The Xert App can see the ANT+ channels but will not connect. The BLE channels don’t appear at all, which is why I’m wondering if there’s something different in how Xert connects to BLE devices generally, or if it’s something unique in the relationship between Xert and that particular trainer.

Hi Geoff,

Can you first make sure the trainer is running the latest firmware? Our app connects to trainers using the Bluetooth Standard FTMS protocol. If the trainer is running much older firmware, it may be using a proprietary BT protocol that isn’t implemented in our workout players.

You can also try removing the trainer from your phone’s native BT menu (if you can) and try pairing the trainer from directly within the app. If you’re still having troubles, please reach out to our tech support team so we can take a look into it.


Hi Scott.

  • Elite’s Upgrado App tells me I have the latest firmware.
  • I have removed it from my Pixels native BT menu.
  • There’s been no change on the BT front doing those things. The BLE channels are still not visible to the App.
  • A separate test with the Xert App on my iPad returns the same results.

What I did do that I’ve had success with however, was to delete the ANT+ Radio Apps from the Pixel, restart it and then reinstall them, and in doing so I can now connect the Trainer and all other ANT+ sensors and use the App. Or I could yesterday.

I’ll email tech support on the ongoing BT issues.