XERT Android App power issue

I have been using the app for a year or more. Recent change in October (?) removed the power match option (or streamlined it and it’s no longer accessible). Prior to October, I never had one issue with the app. I’m using a Power2Max Classic power meter and a STAC Zero Halcyon. The issue seems to be how the app is reading the power from the P2Max. Using Zwift to set the power to 150W (ERG mode), I get readings in Zwift from P2Max at 150W (±2W), 150W on a Wahoo Element and 150W on a Garmin 920 watch. However, on the XERT app, the power wanders from 95W to 165W every 0.5s or so. If I try to control my trainer with the app, everything just goes bonkers.

I might be wrong or slightly off, but I think the original P2Max used two power channels, but only one was real power and the other was for L/R balance, or something along these lines, and it’s confusing the app?

I’d really like to use the app instead of exporting my workout to Zwift, then back in XERT…

1 Like

iOS or Android? ANT+ or BLE?
With a specific issue like that you are best off filing a one on one support request by contacting support@xertonline.com.

Hi Guillaume,

Correct. Powermatch is enabled automatically when the “power” source is different than the “trainer control”.

@lordhong Are you connecting to your sensors via ANT+ or Bluetooth?

This might be something to report to our tech team via email so we can investigate on our end.

I connect all devices via ANT+; P2Max Classic was only ANT+ (I use a Samsung S9+ for app)

I have the same problem with the same powermeter after October’s update. I’ve reported details including the .fit files from my cycling computer and from GoldenCheetah to the support, but the problem is still not solved. Perhaps this is due to auto-calibration of powermeter.

Does everything work as expected as long as the power meter isn’t connected during the workout?
How far off is your power meter from your trainer power accuracy? 1-2% difference or more?

For me, the STAC isn’t very precise, so powermatch is needed for it to be consistent with the P2Max.

UPDATE: This issue should hopefully be sorted now :slight_smile: