Wrong date when completed workout

I just completed a workout using the Garmin connect app on my 530 and when it uploaded it uploaded on yesterday’s date and not today. I am guessing there isn’t a way to fix that upload but how do I fix it so it doesn’t happen again tomorrow? This is the first time doing a workout using xert on my Garmin.

Not saying you have the same issue, but if you used your Garmin with an indoor profile and GPS off, it won’t update the date. I thought it would get the date from your phone, but it needs GPS. Scratched my head the other day when I couldn’t find my ride - turned out the date was November 30 (2019)…

Yes, I do use it inside with GPS off but I have been doing that all winter using TR and haven’t had any issues with it until I used the Xert training app on my Garmin 530.

Okay, I just noticed it the other day, but mine had been off for months. It didn’t update the date, nor the time, so I googled it and read it needs GPS. And I wasn’t using the Xert app, just the recording function…

Have you updated the firmware on your 530 recently? Sometimes firmware updates can mess with the date/time. As Robert mentioned, try to simply get a GPS lock to update date/time.

If you’re still experiencing issues, kindly send a note to our support team and someone can take a look into it

Well, actually I did update it, last week, before I used it… I then figured out what the problem was, after the workout, and let it pick up a GPS signal, which set the date and time to what it was supposed to be…

I will try that later but I don’t think it’s a Garmin issue, I think it’s the Xert app issue. I have trained all winter without an issue using my Garmin with the GPS off and have zero issues until I I tried the Xert connect app on my Garmin 530

You probably never power it down completely, but just put it in stand by mode? I usually do when I use it daily - outdoor season - but the battery on mine was ‘dead’ after laying around for 3 months…

Nope, I power it off whenever I’m done using it. No big deal, I’ll see how it downloads today and report back.

I trained last year with Xert IQ on Garmin 1030 and never had a problem with the date/time stamp on indoor workouts.
It has been a constant issue this year with the latest Garmin updates installed on the 1030. Same Xert IQ app, different Garmin firmware. Draw your own conclusions. :slight_smile:
A telltale symptom is the clock time will be off such as 10pm when it’s really 7am.
My new routine is to start the Garmin in Road ride mode, hold the unit by the window until GPS locks, then switch to Indoor ride and load Xert IQ.
That avoids the hassle of trying to find errant workouts and fix the date/time stamp with FitFileTools.

That is what I did yesterday and it uploaded the correct date. I guess I’ll we’ll have to do that moving forward until a fix is out.

I happened to me the other day. It can’t be that hard to implement getting date and time from your phone instead. Depending on how long you haven’t used your unit, it can take a while before it even gets GPS data.

I don’t know if you managed to resolve this issue at all but today I had a similar experience and found a solution.

I completed an outdoor ride recorded on my Garmin (NOT using the Xert app) which was automatically uploaded via Garmin Connect to Xert - except it was uploaded to yesterday. I deleted the activity on Xert through the planner and tried uploading the .fit file which I retrieved from Strava - again the activity was showing I completed it yesterday. I again deleted the activity on Xert and instead performed a sync from Strava to Xert for the activity and now it is showing that I completed it today which is correct.