Workout player stops after 2 or 3 minutes

Tried the workout player today (Win 7 system) and although the workout played fine on my Garmin the player on the computer screen would stop every 2 or 3 minutes. Only way to get it going again was to relaunch Garmin Connect on phone. Was a persistent problem, not a one off, also happened several hours later when I started a workout and just let it run (no powermeter or bike), 3 to 5 minute max runtime before stopping.

Also, on Garmin 520+ during the Xert workout a lap screen appeared every 5 miles while your app was running. That doesn’t happen on the Garmin otherwise. Checked all the Garmin auto features and they were off. Does Xert cause those auto laps?

Hi Ken, are you referring to the remote player? Or the screen on the Garmin device?

And we have disabled autolap in the app since the lap summary obscures the screen, making it difficulty to read the current/target power. And you don’t have autolap enabled for any of your activity profiles?

Re: hanging or stopping of the workout - I’m referring to remote player, the window on my computer. The Garmin workout app doesn’t hang, it’s fine.

Re: autolap appearing and obscuring the screen - I’m referring to the Garmin 520+, I only have one activity profile on the Garmin and auto lap is disabled.

Remote player should be working continuously. We haven’t had any reports of this since we updated it a few months ago. Internet connection is all fine where you’re training?

Re autolap: We heard about this in the past but nothing recently. We’re wondering if the issue has to do with deleting the activity profiles. Since laps are assigned on a per profile basis, the deletion process may leave somethings behind. Not sure… just speculating… the last reported issue with this, the user had also deleted profiles.

Can you try adding back the other 2 profiles that come pre-installed on the device and see if the autolap issue goes away?

I never deleted the other two stock profiles, I just meant I don’t use them. And I checked them, Autolap is disabled in both.

Hi Ken. We’ve had this reported once or twice before and frankly we’re a bit stumped as to why the Garmin triggers autolaps when the setting is off on the profile. Some of had only one activity profile so the thought was it had to do with these. Some have resorted to a full factory reset to resolve the issue. We’ve issued an incident report to Garmin but it hasn’t yet hit their priority list of fixes. Sorry you’re having trouble.

Today I did a training with the player it only was not on an indoor trainer, but outdoor. Faced the same problem, after several minutes the dashboard topped and I had to re-connect to make it work again. You understand that this is very annoying … Hope I did something wrong and not the program :wink:

Did an indoor workout today that I switched up last night; the Garmin Edge ran it fine but the Player on my Macbook wouldn’t recognize it and showed the title of the previously recommended workout…wonder what I did wrong. (Just joined Xert, like it so far!)

Hi Vince,

Welcome to Xert! Check out our FAQ on the Garmin Player here:
Also, make sure that 1) you have an active connection to your phone while doing the workout and 2) the remote player is enabled


Read it and found some useful helping points, but jot why I sometimes have to reconnect as I have a good connection with my phone… hope that there is a solution for this as I like the workouts… thanks

Jan, you’re experiencing issues with the remote player? We haven’t had any reports of this since our remote player update a few months back. If so, could you include details about your setup (Garmin device, trainer, phone, etc.) in an email to the support team so we can take a look into it?

will do that Scott… great service…

I tried the player on a Garmin 830 for the first time tonight and couldn’t get it to work for more than 3 minutes. Though I have a Kickr, I prefer rollers and was on them instead. So - just using a regular power meter. I tried multiple times with the player window open on my mac, then shut down the player, then restarted my phone and tried without the Garmin connected to the head unit. Everything resulted in failure.

hello, same problem, xert player in Garmin 530 … after 2 or 3 minutes locked timer … tried reinstalling and same result

Do you have other data fields installed? I uninstalled My Edge2 and that fixed my problem…

I uninstaled and removed from the folder in pc… That fixed the problem thx


Had the similar problem: player stopping after few mins. Uninstalling MyEdge2 solved it.