Updates to Xert Player and Focus/Strain App

We pushed out a minor update to the Xert Player for ConnectIQ that addresses powermatch issues for trainers that have very poor power data. Please reset your powermatch settings using Garmin Express or Garmin Connect Mobile by updating the app setings. A new Focus and Strain app was released that better matches Focus values on the app with those on Xert Online.

Armando, I just did my first hardness workout. Really liked it, but have a few questions. First of all, I couldn’t get my Kickr to erg mode, so the workout wasn’t being controlled. Is this related to this minor update, or was I just unable to find the setting? I’m using the ConnectIQ app on my 510. Secondly, it seems these workouts are dynamically setting the target MPA throughout the intervals based on my progress to that point. However, on a couple of intervals I ended up well below the target MPA. I guess this wouldn’t be a problem in my Kickr was an erg mode, but since it wasn’t, is there a way to dynamically target the time of the interval so if I get to my target early, the interval ends? Finally, I’m about 5% stronger sitting up on my bike as opposed to in TT position. I want to do these workouts in TT. Is there a way to scale my entire power curve down by 5%? I tried manually changing my FTP in the workout screen before loading the workout, but that didn’t work. All in all, great workout and product!

Hi Chris. Thanks for your comments! You should setup the KICKR on the app if you haven’t done that. Click the BACK button and choose SELECT. You’ll need to disable/remove it in the Garmin Sensors menu first. Also make sure you don’t have the trainer connected to other software (like Zwift) that could mess up the control signals. It should just work when configured this way and will also just work when you have a power meter with powermatch.

The Hardness Tests are intentionally designed to be fixed duration intervals but use variable power to help you hit your target XSS for each interval. The idea is to accumulate incremental XSS over the exact same period, using the same workout pattern to see where your hardness stands. They are excellent workouts in-and-of-themselves and can be used in a regular workout rotation, even factoring in their specific XSS totals to align with your changing Training Load.

As far as having a different signature, we don’t have way to manage multiple signature profiles but you can temporarily assign a different fitness signature by manually changing it in My Fitness / Advanced page and saving it. When you open the workout on the player, you’ll see those changes reflected and applied to the workout you chose. Upon completion you can then change it back or update it accordingly. Saving/locking a signature to an activity ensures that MPA and other strain/focus metrics use the assigned signature and keep it unchanged as preceding activities may get added or updated.


Having issues updating new Focus/strain app. I tried updating the Focus /Strain app using Garmin Connect and it says it’s on my Edge, but says signature error. I then checked the code and it is correct. I then went to Garmin Express to see if it was there, and it is not shown. Synching does not help either. I thought maybe, I should nstalled it on GE as well, but it did not help.

I notice that there are two PRG files for focus/strain. One from Garmin Express and adifferent one from Garmin Connect. Is this what is causing the issue?

I tried making sure both code matches on both GC and GE, but no luck.

I tried a few different signature codes, and it works for me on the edge820 using Garmin Connect for Android.

If you’re copy-pasting the code, make sure there isn’t a leading space in the code. I noticed that when highlighting and copying the code from https://www.xertonline.com/garmin-connect/iq that an extra space character is added before the actual code, which would mess up converting the code back into a signature. For example, “3neisL” would appear as " 3neisL" when pasting into Garmin Connect or Express.

If you’re typing the code in manually, does your signature have similar looking characters, like 0 O o, 1 l i I, 2 z Z, etc.? The code is upper/lower case sensitive, as well.

My sig code is O0fYkk Cap letter O and then zero 0 and no space in front. Still getting -1 error. When I leave the code at default which is 3neisL, I don’t have any error, but that is just a default code and not my personal code.

LAST time I uninstalled GC and reinstalled which is a drastic measure. That worked. I think I’ll do it again later on after I get hoe from work.