The website's certificate has been revoked

It is impossible to get to the homepage: /

It’s not our site. It’s a known issue with Safari. Try using Chrome until the bug has been fixed in Safari.

I don’t use Safari.
“MS Edge” browser from Windows 11

You might need make some settings changes on Edge. It works here without problem. If you continue to see issues, you should contact and we can try to troubleshoot this with you.

This is my “Edge” setting as in your screenshot.
Tomorrow I will send an e-mail to you, today it is too late;)


I did a search in ESET’s “Knowledge Base” and found this:
After disabling “SSL / TLS filtering” your page will load.
But that is not the solution to the problem.
By disabling SSL / TLS protocol filtering, you weaken your machine’s security layer.

Please bring your certificate to a usable condition so that your clients can use the services without lowering their security level.


You could try again in a few days. The ESET logo shows that your antivirus (ESET) is intercepting HTTPS on the connection to It appears to think that the certificate has expired. I tried the tool linked on that eset article you linked ( ) and that appears to also think the certificate has expired, so it’s not just your computer.

It works for me on both Firefox and Edge though.
If you click ‘View Certificate’ then you should see something like this:

If you see a certificate issued by LetsEncrypt / R3 then that’s the correct one. Your computer might have an older expired one, in which case you might need to wait for an Edge update.

Certificates periodically expire and get automatically renewed (by LetsEncrypt). The one doesn’t expire until November 26th but some browsers might automatically display that error if it’s set to expire soon, or it could also be related to the recent expiry mentioned below.

For @xertedbrain: it could maybe be related to this: DST Root CA X3 Expiration (September 2021) - Let's Encrypt

Exactly as you wrote - Let`s encrypt verifier and SSL/TLS filtering module in “ESET Internet Security” find the “” certificate unreliable.

And you are right again, the problem affects everyone who uses, for example, “Edge”.

I hope that the administrator / operator of the site “XERT” will lead to compliance with the web standards and security of the entire domain.


Simple test –
Remove ESET Internet Security from your PC.
Run Edge and load
Does it work?
If yes, nothing wrong with Edge or the certificate…
If no, make sure Edge is up-to-date and try again.

Thanks for letting us know. We simply updated the existing certificate and it appears to resolve the issue for MS Edge. Looks like there we some snags picked up by MS Edge with previous certs provided by Letsencrypt.

Oops … Are you for real?
It has been documented above that the problem is with the certificate and a very “vigilant” ESET has caught it. Are you telling me to uninstall AV/FW? :smiley:
Advice like “cut your hand if you have a cold” :wink:


Thanks to @xertedbrain - both the home page, blog and XBLPodcast are now working properly.


Bring back bleeding :grinning_face_with_smiling_eyes:

I asked you to test Edge without any 3rd party security apps installed to confirm whether ESET is being more aggressive to alert you of a potential issue.
There would have been many more reports if Edge (Chromium engine) or Chrome wasn’t working for the vast majority of visitors.
As to merits of 3rd party security apps versus Window 10/11 as a service with built-in security suite, that is well argued elsewhere.
I expected you would reinstall ESET after the test.
At any rate I’m glad the problem has been resolved to everyone’s benefit.
Enjoy your ride.

Hello Friend @ ridgerider2.

Maybe I expressed myself a bit too bluntly - forgive me, I didn’t mean to offend you. After all, you want to help.

In the third post, formally, after you led to the trail - I turned off checking SSL / TSL filtering in “EIS” and everything worked. So there was no need to uninstall the “ESET” package.

The ball was on the side of XERT and his certification.

As it turned out, there were problems with him.
So all’s well that ends well - thanks to ESET we managed to solve the certificate issues for the “XERT” platform

Thank you for your help and sorry again.

1 Like