Sync problems

Today I registered and did first workout.
There is no sync to Strava and can’t get it to work.
I disconnectand connected again.
All boxes checked and Strava activities are synced for half Jan up to now, so there is a connection.
Also strange there are no older activities from Strava (Yes I gave a period in the past but this doesn’t work)
It’s a bad start because I need the activity in my trainingschedule and therefor it must also be in Strava
Are there problems with Strava!?

There are hick-ups sometimes and also delays if you have a lot of data. Did you tick/select all appropriate boxes? Not sure what the default is, but for instance you might miss virtual rides, if not ticked. Not sure - just trying to help…

Most requests here are picked up soon-ish by support, but sending them an email is quicker sometimes (

Thanks Robert, Yes all the boxes checked (from Xert to Strava, Strava to Xert). Strange is that it says “no unsynchronised activities”.
Connection must be oké because it syncs last three months from Strava. Did also sent a mail.

Maybe it takes longer if you sync more. They might have put a cap in place to avoid too many API calls. They’ll sort it out for you, but although more is not a bad thing, in theory three months is enough, IF you’ve done a good mix of workouts.

Strange, always work on iPad (mini). Now tried the sync on laptop and for the activity done it worked now! Old activities in the past still not show up (did see them and checked the boxes and pressed sync). perhaps it indeed takes a long time in Xert. We will see.

Did you sign-up for a subscription or register for a 30 day trial?
I think the trial is limited to 3 months of historical data.

Everything is syncing and updating fine, it’s just the notifications aren’t displaying properly. We’re aware of the issue and it should be resolved by this evening! Thanks for your patience