Strava Sync not working for me

Is the Strava Sync no longer functioning for anyone else? I cannot sync any rides from Strava into Xert.

I’ve tried disconnecting and reconnecting my strava account but it still isn’t working.

Same for me. Neither works file upload

1 Like

Same here, file upload not working.

Same here - Sync not working - upload not working. The curse of the Friday release :slight_smile:

Here the same issues also with Garmin Connect no upload. I try it manual same problem :woozy_face:

Yup, doesn’t work for me either.

I was just about to post the same thing. I used my Hammerhead K2 for a session and it did not sync direct from the EBC app. I used Zwift for eye candy so I downloaded the fit file and tried to manually add to XERT and nothing happened. I then added the fit file to Strava and trued to sync from XERT and nothing happened.

Ok, not just a me problem then. There must be a bug or problem with the servers. Hopefully this gets resolved quickly.

It looks like it works in principle, things are just super slow.
Probably reprocessing tot of activities to apply the new decay method.


I got the notification that my account was being upgraded, and yeah, sync stopped working. I can see today’s ride but it’s not going in, disconnected and reconnected like others.

Yes I got the same notification “Your account is being upgraded. Yayy! New features!..”

It’s still down.

I mean to be fair it does look nice and tidy now. Maybe I’ll check out the planner while they fix Strava.

1 Like

:rofl: :rofl: :rofl: indeed it is

1 Like

Just checked out the planner. BOY is that way nicer. Be great when my ride shows up on it with the little map and everything :slight_smile:

1 Like

Agreed, it’s WAY nicer to view now.

Manual upload of files is not working now either. Slick.

502 Bad Gateway

nginx/1.14.0 (Ubuntu)

Probably worth saying: my ride’s come through now, along with 7 duplicates. Probably better to not keep retrying. Submit once and wait, or we’re adding to the backlog (sorry Xert support people).

1 Like

Looks like it was a combination of users making larger than usual requests, repeating them, then running into Strava limits, then repeating them again, and so on.

We bumped up our processing capacity and that allowed the backlog to whittle down and now everything is back to normal again.

Sorry for the hiccup.


Thanks to you and the rest of the Xert team for fixing it.