Setting Android Player via BT

When I installed Xert Player on my Edge 1030, it freezes often (no other apps or datafields). So I decided to try Android App, but setting is really difficult and even after trying different setting I cannot make it work and there is no guidance how to set it up. This are devices connected.

when i open Trainer Elite Rampa, i get this setting - cadence and speed 2x. and last image is from Favero Assioma duo (firm. updated) . I get insane speed, and no power data, dont get powermatch option. I found similar topic here New Android Beta App has me beaten, where is adviced to you Ant+. I have Android 9 phone and there is no Ant+ and I dont want to buy dongle just for using player. Is there way to make it player work via BT as my Edge 1030 (9.1) freezes when using player I might end up without option to ride any Xert workout?

I’ve had an absolute nightmare trying to get the android app to work on my Samsung phone. Neither BT or Ant+ works correctly. There are so many settings available that its mind numbing. If you manage to get it to work please let me know how.

At the moment I’m having to download each days zwo file and ride it on zwift.

Hi all, I’ll share my setup as it’s likely very similar for most of you here and I’ve been riding this trouble-free for quite some time. When the finalized updated app is out, we will have updated documentation to accompany it.

I am using:
Wahoo Kickr v1
Quarq PM
Viiiiva HRM

Trainer (data enabled):

Power Meter (data enabled):

Speed From Power (data enabled):

Heart Rate Monitor (data enabled):

1 Like

Excellent thanks very much for sharing this Scott. I’ll give it a go tomorrow. I’ve just finished the tour if Watopia stage 1 and need a rest :joy:


Cheers! Also should have mentioned that if you’re not using a separate power meter, you just need to also enable Power, Cadence, & Torque (and disable Powermatch) under your trainer’s sensor. Hope that helps!

1 Like

I’m using a stages cheers👍

1 Like

I am not even getting option “Trainer Control” when Elite Rampa connected

I thought I’d just get it set up ready for tomorrow. It still won’t set up properly with bluetooth as i mentioned previously. You can see on the two images below that both my powemeter and my smart trainer have the option to enable/disable powermatch and trainer control for some strange reason yet yours doesn’t.

Everytime I enable powermatch on the zumo and disable it on the powermeter, it reverts back to enabled on the powermeter and disabled on the zumo.

Why does mine have powermatch and trainer control on both?

I’ve just spotted a new app update available. It wasn’t there earlier because I checked to ensure that I had the latest version. I’m hoping this update fixes the problem.

Does powermatch have to be enabled on both the zumo and the stages pm?

Yeah, Stages software is a bit strange… via BT it wants to connect as a controllable trainer instead of a power meter. No need to enable Powermatch on it. Try to disable it on the Stages and enable on the trainer. Try rebooting the phone after the update.

1 Like

Running latest FW on your trainer? Might need to check for FTMS compatibility with the Rampa.

Yeah I’ve got latest FW :+1:

Okay I’ve just tried disabling it on the stages and it wont save it. It pops back on and disables powermatch on the zumo

Disable “Trainer Control” under your Stages connection (that option shouldn’t even be there but Stages BT connections are wonky). That’s likely the issue with powermatch.

It’s already disabled.

I cant disable powermatch on the stages. It just keeps enabling itself again.

I have a Gen 2 Stages on my other bike but haven’t encountered this before. I’ll try testing with my setup later tonight when I’m back home and get back to you.

1 Like

Many thanks Scott.

Hi George,

So I tested this with my alternate setup, Stages Gen 2 left side crank + Wahoo Kickr v2 and I wasn’t able to replicate the issue. Initially my Stages did want to enable powermatch, but I simply toggled it off and tapped underneath the Stages menu to return to the standard sensor menu. When I went back to Stages, powermatch remained disabled.

If you’re still encountering issues, send our support line detailed instructions on how you’re able to replicate the issue so we can investigate and implement a fix, if necessary. Thanks for your patience! See you tomorrow for the Surplus Seekers ride!

I’ve emailed support

1 Like