Sessions how does it work?

I never tried a session before but today this afternoon I tried the session the “Climbing the Kaunertal Glacier road”.

I was 5 min early so warming-up. I can see on my android EBC that everything is working. Heartrate/power etc. I have the session player running on my (linux) laptop. Nothing happens after the warmup at 12:00.

After a couple minutes I refresh the screen on my laptop. The movie starts. I can see stuck in the middle… but thats it…

i can see the the powermeter works and everything but stuck in the middle is stuck in the beginning and not moving. There is no trainercontrol or something like that. I noticed an attacker error thing on the chat but I dont think that is related somehow.

I included a photo to clarify… I hope

So what am I doing wrong?

Do your solo sessions run fine?
For that you only need to select a session from the Sessions Library or Recommend Training list with Play Now, start EBC on your phone, select the session shown, Start it, then view the Session Player on XO.
It may take a view seconds before the Session Player reflects the data feed from EBC to XO.
If solo sessions are running fine, so should a private or public group session. The difference being a chat box option and leaderboard panel instead of the stats box.

It been a couple of months since I tried a solo session (nov 22) but then i worked ok. I was thinking of joining a group session but for the experience i wanted to try a session with the virtual coach. So i get a feeling what to expect.

So i cycled and restarted Xert - Activity | Climbing the Kaunertal Glacier Road ( but nothing happend. well the virtual coach said nothing and the workout did not start.

I did what you described so I should try again and regard this session as a failed test…

thanks for the reply