Segment Hunter Feedback

Hi. Loving this feature. I have hit PBs and breakthroughs by following pacing which is easy to do. :+1:. I have had a couple of instances where Strava segment has started but segment hunter having counted down, misses the start, shows segment dropping away, then goes back to prowling!! Any ideas why?

Thanks! XSH relies on GPS data coming from the Garmin and during cloudy days, for example, it may miss some segments. If you’re aware of this, click the LAP button and it will start the segment anyways.

:sunglasses:. Thanks Armando. Will try that

I have exactly the same experience Andrew my first segment works correctly but for subsequent segments SH starts counting down misses the start drops away and starts prowling I have lap and auto pause disabled and my GPS signal is strong. I wondered whether having Strava segments active interfered but Armando says not.

Same segment? What speed are you entering the segment?

Depending 25-10 mph. The 6 segments I have loaded are regulars and all follow fine on Strava live segments. I haven’t managed to work out what’s going on. Pressing the 520 lap button can restart it but often it’s still confused. When it works it’s good but Ive stopped using it for now. Tried full install reinstall etc.

There are a few simplifications we made in order to get it to fit it onto the limited memory 520 and 130. How it works has nothing to do with how Strava Live works or is impacted by these segments. Are your segments close together? Do they start a nearly the same point? Different directions? Is one inside the other? Send us your FIT file ( with the segments you had issues with and we can see what might be the reason.

I tried again today on three segments, two of which had been successful before. Failed on all three​:scream::scream::scream: . Same pattern - segment detected and countdown successful, at immediate start showed XSH screen with target etc which instantly disappeared with countdown screen reappearing. Tried lap button which had no effect. At least i knew power target to aim for so managed a breakthrough :facepunch:.

Are you running Strava live segments at the same time? These may trigger laps.

Hi Armando. I don’t think so. I have “free” strava - so I run the strava segments via Garmin connect on edge 1000

Contrary to the above are you now starting think Strava Live segments may effect SH Armando?

Only insofar as they trigger laps. There is no other interaction.

but Armando if strava live and SH are both triggering the same segment via laps maybe that’s an explanation for the problems I’ve reported?

Exactly (although SH doesn’t itself trigger laps). Try disabling strava live and see if the segments proceed normally.

okay I’ll try that Armando thanks

pour ma pars je n’arrive pas a faire fonctionner l’appli sur mon garmin il a rien qui ce declanche

What does the screen show? What is the error? Can you share pictures of the screen?

Hi guys. Removed and reinstalled xsh on Garmin 1000, refreashed segments and headed out to try to nail a breakthrough! Unfortunately same story as above - one xsh worked perfectly as it has all along, two others didn’t (same as before too) and I didn’t nail a breakthrough. Frustrating day all round😱. Any suggestions Armando?