Edge 520 ("standard" version) + Xert Segment Hunter

Hello! For some time, XSH has worked on my E520. No power displayed, only color bars, but it worked. Now, after several second of displaying “Fetching segments…” message, I always get CIQ error icon (“IQ!”) instead of the list of segments. I’ve tried to reinstall XSH several times, I have strava segments turned off, active connection with the phone, phone connected to network etc. Other apps from Xert work perfectly (MPA, Focus, F&C), no other CIQ apps installed on my E520. Could someone help me to solve the problem with XSH?

Hi Marek,

Can you try a delete/reinstall of Garmin Connect Mobile? Sometimes theres a hangup in GCM.

You can also try and reinstall XSH, but after removing it and before installing it again, restart your bike computer so that all old program and data files are erased beforehand. This may help.

Hello again.
I’ve tried both solution.

  1. GC reinstalled. No effect.
  2. XSH uninstalled, E520 restarted, XSH installed: XSH worked (fetching -> prowling). but only once, during the first ride after installation. Each next ride = fetching->IQ error on XSH screen.
    It is repeatable behavior. XSH always works only once, during first ride after XSH reinstallation.
    The next strange thing is, that XSH works, when I start ride without E520-smartphone (Galaxy S8) connection (i.e. with bluetooth switched off).

No difference after upgrading E520’s firmware from 12.90 to 13.00.

Try fewer segments and see if that makes a difference. Send us the .YML file located in your 520 Garmin/Apps/Log folder.

Yeah…looks like then 520 has gotten too stretched memory wise. Looking into it…

Was there ever a solution to this one Armando? Got a 520 but if its a stretch memory wise, it might be the reason to go and upgrade!

1 Like

To bump an old, bit to me still very important thread, I recently had four failed attempts at using the Xert Segment Hunter.
My local club is running solo team events in this time of social distancing. We set out local routes and, as teams, compete for the lowest overall time.
Last week we had four timed sections to complete, each roughly 40 minutes in length. At the start of the week I un-started every segment previously had set and selected the four from my club’s “tour” in the https://www.xertonline.com/segments section of your website.

I had multiple problems getting the Segment Hunter to work unfortunately, from segments starting before I’d even reached them and, every single time, the Segment Hunter application starting off tracking something and suggesting wattage, but failing very quickly- within 5-10 minutes or so it would drop me mid segment and go back to “prowling”.

On my Edge 130, I’d noted Xert’s comment about memory limitations and so, as the week went on I, again, un-starred segments as the week went on. For the fourth “race” I’d just got one starred segment active. Yet tracking the segment still failed.

I’m pretty disappointed- this is about the only competition I’m going to get this year!

Any comments folks? Why did I never get a successful segment hunt? Does it only work on shorter, less complex segments rather than ones 30ish K long?

Do you have autolap enabled on the device?

I do, yes. Is that cancelling the segment hunt for me automatically then?

According to a previous thread, yes. But I’m confused…

Thanks Robert for confirming that. I hadn’t seen that in the documentation, but may have missed it.
I spotted that manually pressing “lap” would send the computer back to prowling… etc, but didn’t expect the computers auto function to do the same.

Perhaps the two activation methods can’t be physically separated in code. But if they could, a positive action like a manual press could continue to interact with the Segment Hunter, whereas a passive thing like the computer counting away laps in the background wouldn’t, it’d be a nice tweak.