Segment Hunter : After Fetching Segments it says no connection


I have the following problem: When i start my garmin, the Segment Hunter (SH) says fetching segments. After 5 minutes it says no connection and the screen shows prowling and no segments loaded.

I have the following setup:

  1. One segment loaded in Xert (flagged favorite) (and visible in my xert under segments)
  2. Garmin Connect mobile app says it is connected with Garmin Edge 830.

Any thoughts?

Try re-inputting your username/password on the Datametrics page for Segment Hunter. Worked for me.

Did that! You mean in my phone-app (@connectIQ?) But no result…thing is: i can type whatever i want, but i get no feedback if my login/password is right or wrong…

Still not working.

Hi @bouwhelm,

Try reaching out directly to our support team via email so we can take a deeper look into this.


Roger, 10-4 :slight_smile:

Did you get this sorted @bouwhelm ?

After narrow things down: i used different phones, different Garmins etc… with help of the XERT Support, thanx for that!

I decided that last option was to change my password (i did before) to a shorter one. My original password was generated by passwordmanager (16 characters). Xert website is allowing it. I think the datafield cannot handle that long password? It was not wrong because is copy paste out of my pass.manager.

But: i changed it tot something shorter, and all is working fine now!

I did the test with the MPA app. That has an red/orange indicator in left. So i could see if the password was correct. After 2/3 minutes it updated. So did segment hunter…

Lets Hunt :slight_smile: