"Restart Required"

Was trying to do a workout today on the Xert player for my Garmin 1000. I have done quite a few without a problem. Today, I got a message “Restart Required” above the field that said the Workout is ready. I have no idea what to do. I cycled the Garmin off and on, relogged on both Xert online and Xert mobile on my phone and checked for an update to the Xert Garmin app. The workout the app is displaying is one that it had selected for me yesterday (that I didn’t get to do) but I had changed the workout online and can’t get it to update nor the Restart message to go away.
Any advice?


Here’s my shot in the dark – :slight_smile:
Have you tried resetting the 1000? (hold down power (’) for 10 secs)
Are any other Connect IQ data fields installed? (remove them)
Does Garmin Connect pair fine on your phone? (restart phone, disable/enable BT)
Is Wi-fi enabled? (try disabling it)

thanks for the suggestions. I’ve done all these things. I still have the Restart Required message and the workout is stuck on one from a few days ago. I really have no clue what to try next.

It might be a Garmin Edge/Garmin Connect error message.
As a last resort you could try Garmin’s “universal fix-it” routine. :frowning:
Remove and reinstall everything from scratch on both the GPS and your phone.

It just worked itself out. Even though I had already logged in/out of Xert online and mobile, I tried everything once again. Resetting Xert mobile a third time did the trick.