Remote Player stops updating (playing workout on Garmin Edge 1030 Plus)

Hey there,

When I am playing workouts on my Garmin Edge 1030 Plus via CIQ App, the Remote Player on my laptop stops updating after a couple of minutes.

This happens every time. Last time I tried, about 10 minutes into the workout.

I am using a Wahoo Kickr V5. The Phone with Garmin Connect is close to the Garmin Edge, all devices should have good Wifi. Using a different browser on the laptop or running the remote player on an iPad did not help.

When I play the workout on Android EBC instead of the Garmin, the remote player works without any issues. I therefore think the problem must be related to the Garmin or to something between the Garmin and the Phone.

Any suggestions?



I have sold my Garmin 1030 but I believe the issue is with the Garmin Connect platform.
First make sure you are on latest firmware release for the 1030 by using the Garmin Express app.
If I remember correctly Garmin relies on the Bluetooth connection from your phone to the head unit to pass the Connect IQ app telemetry to XO through your phone’s Internet connection. So the first thing to try is disabling Wi-Fi on the 1030 and see if that helps.
If not some Garmin users have resolved communication issues by resetting their Xert password in XO then updating the password for Xert on the Garmin Connect mobile app.

Hopefully the above helps but if you continue to have issues you can file a support request with for further troubleshooting.

Thanks for the reply.

Firmware is up to date (6.10). I think you are right, sync is Garmin => phone via BT and then to Xert Platform via the phone’s internet connection.

So, tried to disable Wifi on the Garmin and found it was already inactive. Tried to enable it instead and indeed the remote player worked perfectly throughout the whole workout. But on the next workout, the problem was back.

I will now try to eliminate some other variables (e.g. also had headphones connected to the phone on the 2nd try) and next try updating Xert password as you suggested. Also, I have ordered a new phone today (switching to iPhone), which might make a difference, too.

In case all that should not help, I will contact support.

Had the same issue. Switched to the Android EBC which is a much nicer app and everything is right there on the screen for you

Agree the Android EBC App works great in general. What I do not like about it is that activities controlled via Android EBC are not pushed to the Garmin Connect Platform, they only remain in Xert. You can have them sync to Strava, but I do not really use that.

Since I also have a Garmin Running Watch, Garmin Connect is the natural hub for me to collect everything and distribute to other Platforms from there.

Unfortunately, Garmin hasn’t provided a method for us to automatically sync activities to their platform, like it has done for some of the other “big” players like Zwift. It can still be done (manually) for now.

Thanks for clarification and unfortunate that Garmin is acting like that. Good to know you have tried though. I am aware of the manual import option, but I am reluctant to do any regular manual sync in this day and age to be honest.

Getting a bit of track: When playing workouts via Garmin CIQ App, it would be great if
a) the workout name carried over from Xert to Connect and
b) trainer distance would be written into the activity distance (it is there in the custom CIQ fields, but not in the standard distance field in my case at least).

Would that be possible? Let me know if I should rather open a separate thread for that.

Both of those are already in the file (otherwise Xert wouldn’t be able to extract that information!). Seems that Garmin doesn’t read those parts of the file, possibly?

You could just record the activity on your Garmin in parallel? You’ll end up with duplicates in Xert, but can just delete one…

True, that would be one way of dealing with. Probably less manual effort than manually uploading every time.