Remote Player - I’m always John Doe

I’m trying to overlay the remote player with Zwift on a PC, while controlling my trainer with the workout player on Connect IQ (Garmin 530). All devices are on the same WiFi network, but the remote player doesn’t display the workout data. It says I am John Doe, breakaway specialist, even as the workout player takes me through the selected workout. Am I doing something in the wrong order? I usually load Zwift first. Then I go to Xertonline on my phone to select the workout. Then I sync the workout to Connect IQ. Then I go to the remote player on the PC and size the individual windows and overlay them on top of Zwift. I then start the workout using CIQ and…nothing. Help!

I believe that

  1. your PC running remote needs to be connected to the internet, instead of wifi (by runnung zwift I’d presume this criteria is met).
  2. If you run with garmin CIQ app, the edge needs to be connected to garmin connect (obviuously via smartphone with live internet connection) to send info xert server real time.
1 Like

The Remote Player option also needs to be enabled within the Connect IQ app settings.
You could alternately run the Xert smartphone app instead (no Garmin device required)…

I’m not sure what you mean when you distinguish “connected to wifi” from “connected to internet”? I consider those the same thing??

wifi doesnt necessorily mean internet connection. An internal wifi network is possible without the host having internet, which will enable local file transfers only, although such situations are very rare.

if zwift runs fine dont care about that sentence…

Try disabling Wi-fi on the Garmin. The Garmin device connects to your smartphone by BT and the phone in turn connects to Xertonline using Garmin Connect running in background.

That did the trick. Thank you!