Problems with Quarq powermeter and powermatch (Garmin IQ)

I have a Cannondale bike with a Quarq powermeter and use a Wahoo Kickr. I use the Garmin IQ app on my Edge 1030. So far I have ridden with only using power from my Kickr which works fine, in particular in conjunction with workouts using the ERG mode.

Now, once i tried pairing my Quarq powermeter in order to use this as power source instead of the Kickr it doesn’t work anymore. When I start the workout in ERG mode the target wattage is not used but apparently ERG mode is disabled. I tried deactivate the Quarq sensor and then tried again but with an installed Quarq ERG doesn’t work anymore. The only way to use the Garmin IQ app was to remove the sensor again from the sensor menu. After that, everything works fine again. I have enable Power Match in the Wahoo app and the ANT+ ID is correctly configure.

Strange enough, when using the same setup in Zwift it works fine.

Any guess what could be wrong?

The only thing I would contribute, is that ERG mode cannot be available for your Quark, as it cannot receive commands to set the wattage. You should be able to use it in any setup to report power - and get your avatar moving - but not in ERG mode.

Hello IAmHolland,

That is exactly how I have set it up. My setup is exactly as explained here:

I have used setup c, the power meter is added under sensors, the trainer (Kickr) is not added under Indoor Trainers.

I start the Garmin IQ app Remote Player on my Garmin Edge 1030, once the signature is processed and the workout has been loaded I click on start. I choose Start Later and open the trainer control page. Here I use Select and after a short while my trainer is found (with correct ANT+ ID), I select it and return and click on start again and start the workout.

I even checked that Powermatch is turned on which it is.

Now, I would expect the resistance be controlled by the Kickr but the power readings would come from my Quarq so the Quarq basically sends the power data to the Kickr. This is not the case, the resistance data fluctuates as if either only the data is coming from the power meter or the trainer is set in non-ERG mode (and I can‘t put it in this mode).

Strange enough I can‘t get ERG mode to work even if I deactivate the Quarq sensor. Once I start the remote player it says Quarq sensor found and the same thing happens again. For me, ERG mode with my Kickr and the Remote Player on my Edge 1030 only works if I remove the Quarq sensor completely. Then, everything works fine.

As said before, the powermatch setup works fine in Zwift.

Unless the two power meters differ wildly I wouldn’t bother with Powermatch at all.

somehow the garmin 520s cycliq app didnt work with my quarq as well

support ticket didnt solve the issue

I am using the android app now

What happens when you push the back button to get to the trainer menu and you select “Power Control” ? It could be that the ergometer was holding SLOPE mode and you may just need to tell it to go into ERG mode. Try that out today and let me know what happens.

Just tried, unfortunately no difference:-(

Hi all,

I’ve been testing this here with a Quarq DFour and Wahoo Kickr. Wasn’t able to replicate the problem, but here is exactly what I did:

  1. Remove all sensors except Quarq & HRM. Remove the trainer from the sensors menu (or indoor trainer menu for newer devices). This keeps it simple and makes sure other sensors aren’t mucking things up.
  2. Uninstall Xert ConnectIQ app via Garmin Connect Mobile app. After removing, reboot the Edge device and perform a fresh install.
  3. Re-install the Workout Player and authenticate Xert account by signing in on your mobile device. You will likely need to start the app twice… The first time it starts up it will show the changes made in Version 3.0 of the app.
  4. When the app loads workout & signature, click start and select start later. Then go to the trainer menu, and hit ‘SELECT’. Find the ANT+ id of your trainer and select it, it may take a few seconds to identify.
  5. Once that is done, go back to menu screen and tap ‘POWER CONTROL’ just to confirm that it’s in ERG mode.

Try that out and let me know what happens.

I followed the instructions and still have this problem.