Problem with ANT+ Power using EBC on Hammerhead Karoo 2

Hi! Posting this here first in case I’m just being dumb.

When I use EBC on my Hammerhead Karoo 2 and connect to my smart trainer, I get the choice between ANT+ and BTE. If I connect via ANT+ I can see sensible power values on the “Indoor Sensors” screen, but when I start an activity, the power value on the dial keeps yo-yo-ing between sensible values and zero. If I connect using BTE everything is stable.
If I use EBC on my Android phone, I only get BTE sensors showing up so I can’t see if ANT+ is or isn’t working that way.

Needless to say I’ve done the old “turn it off and on again” routine for both the Karoo 2 and the smart trainer.

Any ideas?

On the Karoo, you’ll need to disable ANT on the unit. Alternatively, switch to BT. The Karoo doesn’t share ANT/BT connections with 3rd party apps unfortunately. Try that. Contact support if you still have trouble.

Thanks for getting back to me.

I have looked at the Sensor set-up in the Karoo 2 (NOT EBC) and there are no connections active (I have ANT+ set up for my power cranks on a different bike but it’s well out-of-range). I can’t see how I can disable ANT+ on the Karoo 2 - I can filter by ANT+ or BTE (and can see my smart trainer in both, but NOT connected) but that’s it.

It’s no biggie… I can live with BTE. I’ll play around a bit more in the morning and if it’s still bugging me I’ll raise a support call.

1 Like

What I’ve found is that I can’t have the same device setup on my Karoo2 and the EBC app (still on the K2).
If your using power meters (eg pedals or your trainer like a kickr) it can only exist in the ebc app, and it needs to be removed from the native K2 setup.

I use different ant heart rate monitors when I do workouts on the EBC app (on my K2), and when I do rides outside using my K2 in native mode.
My Favero power pedals are used in the native K2 setup but not installed on the K2 ebc app.

Annoying as hell but works.


That’s not ideal, by any means.

My current situation:

Native K2 has only one profile, “Outdoor” (because I’ve set it up that way) and knows about my road bike power cranks via ANT+.

K2 EBC seems to have two profiles, “Indoor” and “Outdoor” (whether I like it or not). “Indoor” knows about my smart trainer power meter via ANT+; “Outdoor” knows about my road bike power cranks via both ANT+ and BTE, and my smart trainer power meter via ANT+.

I’ve tried to eliminate any potential conflicts between Native and EBC but when I try to REMOVE a sensor under EBC, it doesn’t get removed - but that might just be me doing something stupid :man_shrugging:.

Anyway, thanks for replying. I’ll dig a bit more when I get the chance.