Powermatch problem

I’m trying to use the powermatch feature in the iOS app, P2Max power meter and a Kickr (1st generation). I think I just need to select the power meter for power source and the Kickr as trainer control - both are cyan in the sensors page - and it should happen. But when I ride a workout the power reported is well below the target power. I know the Kickr reads high so it looks a though powermatch is either not working at all or not working correctly. Resorted to slope mode to allow me to reach the power targets.

Any ideas on what I can do ?

Hi John,

In the Wahoo Fitness app, do you have the ‘Control w/ ANT+ power meter’ enabled? See image below:

Thanks Scott

I didn’t have that set, have done it now and added the correct ANT+ ID. Do I need the Wahoo app running in the background or is it stored in the Kickr? Will be riding outside tomorrow (I hope) so won’t get a real test for a couple of days.

No, it should save to the Kickr. The powermatchshould work by default (even without that option enabled). Sometimes you may just need to pedal a little longer to let our app work out the matching between the Kickr Power and your PM Power readings. Cheers!

OK, just done the first 40 mins of Closer 140 and it did pretty well, certainly well enough to be able to use erg mode.


Another powermatch question - is it possible to use erg mode on the Kickr but read power from the P2Max meter without Xert trying to powermatch? That way it will respond faster for short intervals but give a reading which is more consistent with readings from outside rides.