Power values suddenly zero

Hello, I’ve been on the trial version for 2 weeks. My combination is the Kickr Core with the Android app. Yesterday I suddenly had zero values for the power values. I restarted the workout 2 times, suddenly zero values again. I saved the 3rd workout, see diagram. The value in the app was zero, but you can see 160 watts in the diagram until I stopped after about 40 minutes. I checked the setting of the sensors, also disconnected and reconnected.
After about 26.20 minutes, the app should have adjusted the trainer to just under 300 watts, but remained at 160 watts, according to the diagram, the app display was zero. I wasn’t using another app at the same time. I’m a little at a loss?

Looks like loss of power and trainer control during the recovery interval at 160 which is why the resistance remained at that level and the app showed 0.
It has been a long time since I’ve had any issues with BLE connections but when I was having them restarting the phone was required to get things back to normal.
Android app version
KICKR Core firmware up to date?
Does the Wahoo app work fine when the problem occurs?

Hi Volker. I’m curious if you’ve found a solution to your problem. I’m relatively new to Xert too and have experienced the same problem multiple times. At other times the power will suddenly drop to zero. Sometimes it will bounce back. Unfortunately sometimes the workout is ruined and I have to shut everything down.

I am also using a Kickr Core with the Android app (Samsung tablet). I also use Zwift and occasionally Fulgaz and haven’t seen these issues with either. One difference is that with Zwift and Fulgaz both use bluetooth connections. Xert recommends and seems to favor ant. I don’t know if this is a factor but I am trying to figure out how to get Xert to make the connection via bluetooth if this is possible. With Android it seems to default to ant.

I’m hoping I can find a solution because I really like the platform but the problem can be very frustrating especially in the middle of a hard workout.

Found the cause, I selected ANT + as the connection in the sensor search for the KickrCore during the initial setup. It also worked in phases. The BT connection didn’t work immediately and I was too impatient. Well, it partially worked with ANT +, but not reliably and repeatedly with failures. Since I paired the Kickr via BT, everything has been fine, it’s simple…
Hi Jason my combination is similar to KickrCore, Samsung phone and the Android app. I hope your problem is just as easy to solve.

That was true a long time ago but if you are running the current Android release ( you should have no problems with Bluetooth.
What you may need to do is remove the ANT+ connections listed under Sensors by disabling the ANT+ service on your Android tablet then wait for the Bluetooth connections to appear and pair them as the preferred connection.
For awhile I had both ANT+ and Bluetooth connections listed under Sensors. Now I have only Bluetooth listed and everything works fine.

1 Like

Thanks Volker and ridgerider2. I have switched over to BT for my last couple of workouts and have seen no drops in power. Of course now I have lost an excuse for ending a workout early. (-:

1 Like

I’m new to this forum… so please let me know if this has been addressed.

I’m facing the same/similar issue with Xert EBC (and the old Xert) app on Android.
Power shows just for a moment at the start of pedalling and drops to 0 forever.

  • Power shows correctly on Wahoo App and Spindown completes successfully

All other sensors seem working, but power never shows
It has been working all ok till 2 weeks back and nothing has changed unless the app got updated.

My setup as below

  • Kickr Snap with road bike mounted. (Connected over BlueTooth)
  • Speed from Power
  • Samsung Tab SM -T865 with latest Android (11)
  • Xert latest App versions from Play store (V4.2.2.23 (252))

Troubleshooting I did so far

  • Reinstalled Xert EBC App
  • Used another Android device and tried with the latest Xert EBC app

I have also raised a ticket with support last week which is still under investigation

My initial thought is that something else is trying to grab the BT connection from the Kickr.
You could try removing any apps that may run in background that can connect to the Kickr such as Wahoo’s app but it could also be something like RideWithGPS, etc.
Normally this shouldn’t be an issue (only pair to sensors when app is active) but may as well eliminate all possibilities.

You can also send Xert support a diagnostics log within the EBC app under Settings, About. Preferably when connected and then right when power drops to zero,

Any chance there is a firmware update available for the Kickr or was one installed around 2 weeks back?

Thank you for the reply.
There were no other apps I could see using BT. Kickr latest firmware update was in 2018.
Finally, I joined the Beta program and updated the Xert EBC app with the latest beta version which worked. I had already sent the diagnostics log to support last week itself. There was no response from Support and that’s not a good sign to me. No updates on my ticket at all. I’m a paid customer and locked for approx another year. Pretty frustrated and disappointed with the issue.

Sorry you are having issues.
I notice in the first example no sensors are responding while second example shows HR. Are HR and cadence working fine otherwise?
Do you also have a power meter on your bike?
What happens when you test EBC with your phone instead of the tablet?

Xert EBC for Android and the IOS TestFlight apps have been approved. Update your app and try again. Let us know if you continue to have any issues.