Power meter + smart trainer control config (real power is higher than target)


I have a KICKR Snap and a Quarq power meter. Once everything is warmed up power from the meter settles at about 6-7% higher than the target. Admittedly my config is kind of messed up… I have the PM controlling the KICKR through the KICKR app, but then had XBC controlling to the power meter rather than the KICKR as I prob should have.

In any case… what is the recommended configuration to use my PM?

XBC controls to KICKR power —> KICKR controls to PM
XBC controls to PM and KICKER + PM are unlinked


close your kickr app(make sure it is not running in the background) and open xert ebc with selected as below.

xert ebc trainer control - kickr snap
xert ebc power - quarq
xert ebc cadence - quarq
xert ebc speed - speed from power


This should be the proper way to do it. You can also try to remove the option to control the Kickr Snap with your Quarq PM and just let Xert EBC do that on it’s own (using the sensor setup described above by Peter)

I did another ride with the recommended config above, as well as direct control of the KICKR with my Quarq just monitoring outside of Xert. In both cases the KICKR was still controlling to power about 6-7% higher than what the Quarq was reading. All my Xert metrics are based on my Quarq readings so is there a global setting for me to dial the KICKR back with?

Hmmm…will it be related to powermatch?

if you are using xert ebc ios, check whether can toggle on powermatch.

if you are using xert ebc android, powermatch is automatic.

I am using Android. I also noticed that when controlling to my Quarq Xert seemed to have problems holding lower watts in general. When I switched to controlling by the KICKR it was smooth outside of the power offset.

What gear are you in on the Trainer? If you’re in a very high gear (53x11), it might be hard for the trainer to hold a low power output (~100 W).

FWIW, I use EBC on Android device w/ Quarq PM (DFour) all the time without issues - it’s my primary/go-to configuration for indoor training.

I generally ride at 50x19 or 50x21. Pretty much the middle of my 11-34 cassette.

Is there anything specific I need to do at startup? I always calibrate my PM… didn’t see an option to do a spindown calibration on the trainer.

Are you making dual recordings then analyzing with DCR Analyzer to determine offset?
Is power smoothing disabled on the KICKR so you can compare actual numbers?

Power smoothing is off. I did dual record my last ride but I deleted one of the plots to not have overlap… I should have kept it. I will dual record my next training ride for the DCR comparison.

Can you post a screenshot of the sensor screen on your phone when everything is up and running? Does your phone only have Bluetooth or does it have ANT+ as well?

I don’t know the Quarq power meter. If it is single sided, check if the app for the powermeter has an option that you can activate to double the poweroutput.
I had an issue with my single sided assioma pedals. In the assioma app I have an option that says something like this: double power output - some older apps may require this option.

It turned out xert is such an older app and I had to activate this option.