Obtaining Signature, Login Via Phone...not

For the last several days I’ve been unable to get my workout player to function. I’ve restarted Garmin 820, restarted phone, downloaded and re-installed app, reset everything I can reset. Phone is connected via Bluetooth and I’ve got five bars on my phone reception. I have a Samsung Edge S7. Anyone else having difficulty or is there something I’m not doing correctly?

Is the phone prompting you to login again by chance? Be sure to check your notifications and if you see a CIQ symbol on the top bar, open your notification and login to Xert.

Yes, I receive the notification. I open the notification, go to the Xertonline website where it asks me to authorize permissions. I do. Then it says authorization or login successful and return to your Garmin device. Then I return to the same screen that says obtaining signature…by the way, it’s worked very well in the past. Maybe there’s a new update to the phone. I see the app was recently updated. Was wondering if I’m the only one having these difficulties.

Have you tried shutting down the 820 and powering it up again? Perhaps even a hard reset (hold the on button for 10 seconds).

I just tried it again with no luck. I suppose the next step is a factory reset, which isn’t the end of the world, I guess.

Try plugging in the unit to your computer and removing the PRG files from the App folder, the SET files from the Settings folder and the DAT files from the Data folder. This is a manual removal procedure. Then reinstall.

Success! Thank you!

I’m having the same issue with my 520. For the technologically inept, could you expand on the fix procedure? Specifically, where are these files located and what do you mean when you say, “reinstall?”

You’ll need go to your Garmin/Apps folder and remove the .PRG files, then go to the Garmin/Apps/Settings folder and remove the .SET files and the Garmin/Apps/Data and remove the .DAT files. Then using Garmin Express or Garmin Connect Mobile, add the apps back onto your 520 (reinstall them).

Followed all of that except that the Data folder contained only one file named BOCB.STR. Do I remove that (and by remove I assume you mean delete?)

I didn’t remove that file, but removed the others. If you have any other connect IQ files you’ll have to re-install. After this, I had to reset my garmin by holding the on switch for 10 seconds. Now all works fine. It seems that everything re-installs when you re-download the apps, so it’s probably fine to delete that file, as well. I don’t think I did, however.

Didn’t work. I’m still getting prompted to sign in and authorize permissions. Once I do that, the player shows that it is obtaining the workout, then goes to the IQ! screen. What else can I try?

Never mind. I changed workouts and the player appears to be working. FWIW, the workout I was trying unsuccessfully to load was one that I designed.

The 520 CIQ system will crash when it runs out of memory. You may have too many intervals in the workout.