New Garmin 830 and Xert Workout Player error

Hi there, I have the new Garmin 830 and have been attempting to load the Xert Workout Player app from Garmin Connect IQ store. I get as far as “Authorize” via android mobile phone and get “Unknown Error: 0” on the Garmin. Any ideas on how to load the app? Cheers

Hi Phil, can you kindly send a note to support@xertonline.com so we can get them aware of the situation? They may have a solution that I’m not yet aware of. In the meantime, you can try removing the app, rebooting the device, and trying a fresh install. Sometimes that’s enough to get things working properly.

Hey Phil, can you try uninstalling/reinstalling Garmin Connect Mobile on your phone and trying the Xert Workout Player again? This should resolve the issue.

You can also try turning off WiFi on edge of problem persists. I tried all of the above mentioned methods and still get the error until I switched off WiFi and connection was through and downloaded the workout.i have a 530 5hough.

For future questions alike: I switch to another profile on the Garmin 530 (for example indoor), then back to cycling and then opening the Xert IQ again. This almost always solves it.
I think it has something to do with the connection to the internet. I always first open the Garmin Connect app then I hit the Xert Player on the Garmin.

@stevenvl The issue should now be resolved with the latest app update on the Garmin app store. Try updating the app and let us know if you still have any issues. Thanks.