losing power data on connect iq

I’m running my workouts from a new 530(as in the app is the only thing I’ve added alongside sensors). None of the power data is being synced over.

Disabled my pedal power meter from the sensors list, so the playedris using the wahoo kickr for power reading and resistance(powermatch is on).

Everything looks good from the player. Resistance is simulated correctly. All the fields look correct withing the player for displayed resistance and heartrate.

Any thoughts on why power data wouldn’t be showing on the activities?

Hi Greg. Be sure to read our FAQ on using the Garmin Workout Player. To use powermatch, you need to remove your trainer from the sensors list and keep your power meter configured there. Then setup the trainer in the app. If you only have a trainer and it is setup in the app, you won’t see power data in Strava.

I’ve checked across the different pages on how to set this up. Found the following:

Currently trying to set up just the smart trainer without the onboard power meter. Enabled trainer as a sensor, selected trainer within the app, and made sure Powermatch wasn’t on. The workouts synced to xert analysis are not showing any power data.

I’m able to get power data across if I use the pedal-based power meter with Powermatch, but not using just the smart trainer. I rotate through a couple bikes on the trainer and would like to get this working. Any tips for troubleshooting what it could be?

You can try adding the trainer as a power meter on the Garmin. If you’re seeing power during a regular activity recording, the app should see the power data come in the same way.

Power is the sensor type the trainer is added as. I didn’t see “indoor trainer” as a sensor type for the 530


Thank you! If I add it there, the xert workout player isn’t able to pick it up within the app. Guessing when I have it set through the normal sensors list, that is just power readings. Still weird to me that the workout player functions as expected but doesn’t send back power data on the activity.

The weirdness is due to the limitations placed on the app by the Connect IQ system and how it is able to record data. If you just use the trainer for both trainer control and power, leave it configured as a Garmin trainer and everything will work normally.

Thank you for helping troubleshoot this issue. Any combination of the advice above results on some error, like not picking up the trainer within the app, not controlling resistance, or not exporting power data. Running from the Android app with just the smart trainer works fine, as does running from the Garmin workout player with both the onboard power meter and smart trainer.

I’ll keep you posted if anything changes and I’m able to retain power data through the Garmin workout player with just the smart trainer.

1st post. So, bought a 530 after becoming Xert user. To pair everything with the 530 I used my outdoor bike (that has a favero duo) on the trainer. I paired the trainer, the favero, everything I could. Started doing some rides and love the mpa/power and xss/difficulty fields. Also enjoyed a Dr skiba field that a friend recommended and Strava relative effort.

Took the outdoor bike away and on my first ride with my dedicated indoor bike (that DOES NOT have the favero anymore) and the Xert and Dr skibe fields are completely dead.

They connect but do not receive power. EVEN THOUGH I can 3s power, tss, cadence, the Strava iq field is reading a score. Just the Xert and the other field are not getting it.

After a lot of searching I realize that the trainer is paired as a trainer (as recommended on the link above). I tried to connect it through ant+ or ble but no look. I can only connect the trainer to the Garmin through the training method.

Please help. How can I recover the Xert fields without having to bring the favero back in?


P. S.: I do my workouts in zwift app and my goal is to simultaneously read that into the Garmin and see real time stuff like mpa and xss (both during the workouts and races)

Hi Pedro,

We’ve got your support request and we’ll take it from there!


1 Like


The problem is app tacx utility. In the app, when trainer connected, the app recommends to turn off ant+ spd/cadence/power data transmission. I had it turned off because I’ve never needed it and decided to follow recommendation.

Just turned it on and in the power source sensor it poped up immediately. Solved. YAY!! :smiley: