How to adjust workouts in the planner using the AI Beta

At times my schedule does not allow me to train, I’m using the AI Beta.
How do I move workouts form one day to the next . So today was supposed to be a rest day, so I did tomorrow’s workout since I won’t be able to train tomorrow. What is the correct way of moving workouts around in the AI planner?
Oh, also what do the colors mean in the XSS circles, I have green and red.


You cannot move workouts now. However, if you cannot train tomorrow you should set yourself unavailable that day (using the watch icon). After that you can adapt your plan. Rest day means that you have enough XSS, recovery day means you are tired.

I would like to see a feature that will show how much and how little I can do today while still not destroying the plan. So let’s say I am assigned 100 XSS pure endurance today. Can I reduce that to 50 or maybe 0 and still be able to catch up within the next seven days? Or can I increase that to 150 or 200 and still not be too tired? If I do too much today, Xert might consider me tired tomorrow and put me on recovery, thus loosing a day of training. Or maybe do endurance today instead of a the climbing workout.

If you have played around with Adapt Forecast you know that the current plan is just one out of many possible that will give the same result. If you set you as unavailable one day (and adapt) and then change back the availability (and adapt) there is a chance that the rest day will still be there because all the XSS has already been moved somewhere else.

@xertedbrain Maybe you can add a feature later where you can get a XSS range for today’s training or a few alternatives? The alternatives can be generated with a variant of the Adapt Forecast feature where you search for alternatives that will be zeroed out within a seven day horizon. E.g. maximize the XSS today, minimize the XSS today and do that on both high intensity and low intensity training. You will then end up with the following alternative workouts:

  • Pure Endurance: 50-150 XSS
  • Mixed Climber: 50-100 XSS

The colors mean you are compliant with the workout or not. Click on the XSS circle to see the details. I am not a total fan of the compliance indicators because it makes the plan more rigid than what is required.

Thanks HPB.
I did set myself as unavailable for tomorrow and had xert re-adapt. I am hoping it took into account my two red XSS days that I trained when I was supposed to rest.
If I decide to do a work out on a rest or recovery day do I need to re-adapt?
Also, if I do a workout not in Xert and it is in Strava, then Strava sends it to exert, do I need to re-adapt so Xert can recalculate my future workouts?
Xert has me doing a HIT Mixed Puncheur today, so I’m doing that shortly.
Will check back later.



I’m having similar but different issues. Now that winter has arrived I’m switching to an all indoors schedule, and the AI planner wants me to do lots of long low intensity workouts. Outdoors that’s no problem, but indoors I find doing much over 2 hrs. too much. What’s the best way to indicate that?

Also, I’ve attached 2 pictures that I think are contradictory. On the calendar it says that I should do a ride of 2:40 duration, but if I click on “Set Availability” the advisor recommends a 1:04 duration. Finally, if I choose training, the rides lean towards the 2:40 duration.

Screenshot 2023-12-28 at 10.48.55 AM

I think you should use the adapt feature after skipping a workout or when you complete a workout.

  • When you skip a workout the planned XSS is not produced, and you are behind the plan. The adapt feature will correct that.
  • When you complete a workout you are likely not doing it exactly as in the plan. So you might be a bit behind or ahead of the plan (a few XSS more or less compared to the forecast). The adapt feature will correct that.
  • When you manually add/modify/delete a workout to/on the plan (not as part of the forecast).
  • When you change any of the availability settings.

Ok, makes sense.
Anytime I change something in the planner I will re-adapt so the AI can make the necessary changes.
Thanks HPB.

Thanks @nnovod for posting. The system at the moment assumes that you’re maintaining XSS growth for progressive overload and it doesn’t directly account for duration. In your case, your overall XSS per hour rate is quite high on average (why your average duration is 1 hour and 4 mins but the XSS is 169). This will have the system prescribe more low intensity XSS in order to maintain the progress you need but then it also means that you’ll need more time than you typically have on Fridays.

We’re looking at making some improvements to this that will make more sense to you and other athletes like yourself that have higher overall XSS per hour rates. It may end up giving you smaller Low Intensity training activities to complete but these would be offset by other high intensity activities that the system would prescribe so that you still reach your target.

Stay tuned for some changes to address this. For now, you may want to use a fixed availability for Fridays, for example, if you only have 1 hour or so to train and you’re seeing longer low intensity training activities prescribed.

1 Like

Another case of workouts not adjusting to changes?

Yesterday (Thursday) was supposed to be a rest day, and today I was supposed to do a Low Intensity endurance workout. Feeling restless I did the workout yesterday (same XSS assigned for Friday and mixed endurance) and planned on taking today off. I did a re-adapt of the forecast and was surprised to see that nothing had changed, at least for today and the near future. Should at least today have changed?
Here’s the plan for the week (which started on Wednesday, originally with 2 rest days!) after the new adaption…

Where can I set the unavailability ? Is this before you let AI set your plan or afterwards. I was impressed with the work that went into it (took a lot of time to calculate) but was surprised it set saturday as restday
As a goal/target there is no option to choose a multiple stages race (one week - 5 rides)

In the planner look for the clock icon on the right bottom of the date. Click it and you’ll be able to set availablity.


So I don’t have the clock on my version of my planner MacOS?

After you forecast a plan each day on the Planner will show a clock icon button.