Garmin sensors disabled after using Xert IQ app

Is there any update on the issue where Garmin sensors become disabled using the Xert IQ app? I just upgraded from an Edge 520 to an Edge 1030 Plus. I never had the issue on my 520 but have it on the 1030+. It’s pretty annoying…

Hey Thayer,

We did hear back from Garmin on this issue a little while back. Sounds like this should be resolved…

We made a fix back in September that addressed this issue, and it’s been making its way into firmware since. Incidentally, this affected more than just Edge products (we also had it reported on fenix 6), but it wasn’t easy to reproduce. One of our beta testers noticed that when he checked his widget loop in the morning, it would disable all of his sensors because of one of the CIQ widgets in the loop. :blush:

So what you saw and what my team saw while testing, where sensors would be disabled while running a CIQ app but then immediately re-enable and re-connect after exiting the app, is normal behavior, and your users should receive fixes for this in firmware updates, if they haven’t already.

Sounds good. I guess they mean it is still being rolled out. Maybe the new Edge 1030 Plus firmware that is currently in beta testing will fix it. Thanks for the update.

I have an Edge 1030 (not plus) and I haven’t noticed the disable/re-enable but I just do the workout and then am off the bike. I have noticed that some update in the last month or so has frequently caused my sensors to be disabled when I come back and turn on my Garmin the next day and I have to manually re-enable them.

I have the 1030 plus and am experiencing the same issue after an xert workout using the IQ app on my Garmin. Only a minor annoyance to switch them back on but hopefully, it will be resolved soon.

Hi Scott.

Keep checking for firmware updates from Garmin. They’ve let us know that the issue was resolved with a firmware update. Hopefully it’s fixed on your end soon!

Perhaps included with these updates?

It’s not fixed for me (Edge 530, software version 7.00)

Edge 830 running the latest firmware (v7.00) and the disabling of sensors is still happening. Pita!

Also on my Garmin Edge 1030. After a workout with Xert every sensor is disabled.

+1 also still happening here.

Still happening with my up-to-date Edge 1030. Specifically a pain when you stop a workout quickly eg realising it has started the wrong session and you then have to go into each sensor and re-enable it.

Also not fixed with me

Hi Bart,

Can you check to see if you’re running the latest version of the app?

Still happening. Edge 1030 plus, 6.22 firmware, Xert app up to date.

Hi Scott,

Yes I am running the latest version. I also tried uninstalling and reinstalling the app. No success :frowning:

1 Like

Also still happening here with a Garmin ?Edge 530 and up-to-date software