Garmin Drop Out - Is it Xert?

My Garmin goes into sleep mode and shuts off when I scroll away from the screen with my Xert apps. This has happened three times on three different rides and did not happen prior to installing the Xert apps. This is not to say that the Xert apps are causing it, but it is highly suspicious given that each time it happened I was scrolling from the screen with the Xert apps to a different Garmin screen.

The effect is that I immediately turn the Garmin back on, select resume ride, and all is well. However, It’s frustrating because it resets my MPA and my drink timers. It would also be really frustrating if I didn’t catch it, but so far it only shuts off when I’m looking directly at it switching screens. No, I’m not accidentally hitting the power button, but I think Garmin actually requires you end the activity before that button will work anyhow, which also implies a glitch.

I am running the MPA/Power, Focus, and TTE/TTR apps. All are on the same screen. I am logged into all of them. The first two work well; the TTE/TTR has never worked - it’s blank and just shows the Xert logo.

This may be an issue with my device, but I don’t really think so because it just started since installing the apps. Has anyone had this issue or reported anything similar? Any suggestions?

Been a while since I used a Garmin (sold my 1030 on eBay) but I remember you need to configure the numbers you want to use for TTE/TTR as noted in this article –
How do I install, configure, & update the Xert Garmin ConnectIQ Apps? – Xert (
Also shown here – Ride to Xert's Focus Metric with Scott - YouTube

I gave up on Garmin as there were too many glitches (all Garmin related).
Sometimes Garmin Connect would simply not connect to the device no matter what I tried.
I also experienced issues whenever firmware updates were installed.
One workaround I had to use (several firmware versions back) was to disable Wi-Fi when not needed, but I forget what that resolved. :man_shrugging:
Another workaround-fix was to remove other custom data fields (non-Xert) that may interfere because they run in background even when not being used.

If you continue to experience issues, I suggest checking the Garmin forum to see if any similar reports posted for the firmware version you are running.

Not saying it isn’t our apps, but that sounds like a Garmin auto-sleep setting that should be checked… see support docs here: Edge 530 - Using Auto Sleep

Our apps don’t shut off devices, they simply make some calculations and display metrics based on the power data coming into the Garmin.

I actually disabled this setting two rides into using this bike computer because it was so annoying. This isn’t an issue with the screen turning off, it’s an issue with the device completely powering down. When I press the power button to turn the computer back on I have to wait through the Garmin splash screen. It completely resets the stats on the ride, though it does allow me to resume from the point it shut down.

I will email Garmin support because it is likely an issue with the unit, but I figured I’d ask since it coincidentally has been happening when I scroll to check my MPA.

I would love to do this but I am pretty invested in the Garmin ecosystem at this point. I have years and years of swimming, biking, and running saved on the platform. I have had pretty good luck with their customer service, but their products are buggy, Garmin Connect is unnecessarily complex, and the FirstBeat training advisor is complete garbage.

Maybe I’ll switch to a Wahoo or something if this ‘power down’ issue turns out to be a faulty unit.