Garmin Data field not updating - Garmin Edge 520

I’m having issues with updating the data fields, and have the Xert Connect IQ App to refresh and display the updated power fields and suggested work out.

I’ve tried deleting the app and the data field reinstalling them and I have also wiped my Garmin edge 520. Nothing seems to refresh and update. Of course I have the proper passwords and user ID to sign in.

I can confirm that my Garmin edge is correctly connected to my phone as I can sync other data back-and-forth. I did look through the community board to make sure that this issue hadn’t been resolved by another member but could not find one.

Thanks for your help in advance

I had this problem a couple of weeks ago. It turned out the payment for the subscription wasn’t paid because I had a different credit card. After paying it all worked again.

This is happening to me, also. I can’t seem to get the data fields to update. I have followed the instructions here and entered my credentials, but even after an hour of riding the dot stays yellow. I am going to try resetting everything and re-entering my credentials, but if that doesn’t work I am at a loss. I’d really like the MPA and Focus fields to be accurate – it looks really handy but I can’t seem to get it to connect and update the signature.

Same issue here.
I choose the workouts and save in the planner but then when I activate Xert IQ on my Garmin 520 it shows everyday always the same workout I did last week.
Help please!

Placing workouts on the Planner does not make them the selected workout for the day unless the time stamp is close to when you start EBC or the Connect IQ Player.
For example, if you added SMART - Learning to Survive to Thursday on the Planner and set the start time to 8:00 AM, that workout will be the selected workout if you start EBC or the Player prior to 8:00 AM on Thursday.
You can confirm if the workout has been selected by viewing the Training tab on XO (under the Recommended Workouts list).

There have been reported issues with Garmin Connect not synching to the Xert Connect IQ Player. This is usually remedied by re-entering your Xert credentials in Garmin Connect on your phone.

Just tested on an Edge 1000, 530, and 1030 - no issues here.

Double/triple check password. Try turning WiFi off on the device. Switch Garmin profile back and forth to force the data field to refresh the settings.

Many thanks.
Form Scott (Xert) I got this response to my problem: “what time are you planning/scheduling these workouts in your fitness planner? And when are you actually completing the workouts? A planned workout will become selected in the workout player approximately 2 hours before it’s scheduled time.”

I tried and it worked.

So the point is to pay attention to the time scheduled for w/o.
In fact any w/o saved in planner comes at 23:59 hr.
Is it possible to set at a “current time” instead of at 25:59 ?

s.

Thank you for all your suggestions I will try and see if logging in and out helps and like Scott has pointed out, see if switching Garmin profiles works as well.

This battery of suggestions worked. Thanks, Scott. I now have the correct MPA, Focus, and Difficulty. The TTE and TTR fields still only show the Xert logo, but that may be because I’m not actually on a ride right now? I have green dots on the other two apps though, so that’s exciting. I can’t wait to check this out on my next outdoor ride! Chasing the default MPA was getting rough :wink: .

Managed to do a few test with my Garmin 520+ and I noticed the following: on my iPhone’s Bluetooth connection I can tell that there is two Garmin device is connected (see attached screenshot) and those two devices are the same Garmin 520+ (one of the connection is like a ghost connection). If only the G Edge devices is connected, the data fields do not update but if I connect both devices, then the data fields update. The unfortunate part is I have to manually tap on the BT_Edge_520_Plus to get it connected and update the data fields. I’m assuming this is a Garmin issue and definitely not an Xert issue.

Has anyone encountered something like that? I’ve never had any issues in the past.