For people having issues with their Garmin and Xert datafields:

This procedure completely removes all Xert datafields and re-installs them. Issues are occurring because there are some that are only partially upgraded using Garmin Express or Garmin Connect Mobile. This is an issue with these software programs.

  1. Completely remove all Xert datafields on your device. To do this, you may need to switch to another Activity Profile or remove them from your Activity Profile. If you don’t you will get errors trying to remove them. You could also try using Garmin Express to remove them.
  2. Once all the datafields are removed. “Safely unplug” your Garmin if you’re using Garmin Express and then shut off the unit and start it back up again. No Xert Datafields should be on the device when you use Garmin Express or Garmin Connect Mobile at this point.
  3. Plug the unit back in / use Garmin Connect Mobile and install the Xert datafields onto the unit.
  4. Configure them with your username and password.
  5. Add them to your Activity Profile.
  6. Start recording and they should now update and show a green dot when the update is successful. When you s top recording, the apps save your signature for use with your next recording. They will also attempt to update with each new recording.

Done like said, but can’t get the TTE field configured. All other fields work as they should. In the TTE field I only get a Connect icon with question mark.

This means either it hasn’t be properly removed or your settings may be invalid. Are you using defaults or are you using different settings?

The problem seems to be that I can’t change the values in Time-to-exhaustion watts and time-to-recovery watts. If I leave them on default, it works.

What are you changing them to?

I have this working fine on my 1030 which I set up a while ago. This evening I tried to set up the XERT fields on my 1000 and 820 devices but they would not update. I removed the fields using Garmin Express but the fields would not disappear from the Connect IQ field selection screen on the devices even though they were no longer showing in Express. I even performed a factory rest on my 1000 and the fields were still there. I finally tried removing the fields using Garmin Connect on my phone - that worked. I was then able to go back to using Express to add the fields and set up the userid and password for each. The fields are updating now.
I wonder if the latest Express update (ver. messed something up with IQ.

Another Garmin 1030 with all working except TTE. I get IQ! in that field. Settings: TTE Watts: 250, Target MPA 1159, TTR Watts 125, Target Recovery MPA 1200.

Target MPA has to be below PP and above the the TTE Watts. TTE Watts has to be at least your 20 minute power. TTR has to be below TP.

Thank you. Got it squared away.