Fat and Carbs Data Field not working on Edge 820 :(

Downloaded the Xert Player as well as the other 5 Data fields plus the Cadence Optimizer plus the newest What’s My FTP.

Everything was downloaded, installed and configured via Garmin Express and everything works fine but the Fat and Carbs (v 1.3-upd).

Unistalled and re-installed via Garmin Connect Mobile - no joy!

Tried several page configuration (from only 1 field to 10 fields) - no joy!

Every time I enable it, here’s what I get: Yellow Exclamation Mark

In a SINGLE occasion I got a different icon Xert Logo

Here are my device’s details Devices Details

Any thoughts?

Your help will be greatly appreciated :slight_smile:

There have been others that have experienced this on Facebook. We are not able to reproduce it unfortunately. Moving it to a new cell appeared to have worked for some.

I’m having the same problem, but on a Garmin Edge 520 (Software version 12.10).
I’ve installed the 6 Xert data fields and the app, but it’s only the “Fat/Carb” one that comes up with the “IQ” display.
I’ve tried it in different display segments - as a single field on a 10 segment display and as a double field on 5 segment displays. No dice.
What I have noticed is that when you first turn the Edge on and preview your activity page, it looks like its going to work - you can see the labels in the field rather than the “IQ” message. However, once you go back to the main display and activate your activity (i.e., for use), that’s when you see the “IQ” message.