Edge 1030 plus, updated fields and crash-loop

I just installed the updated fields. I have a datascreen with 3 CIQ fields - “What’s My FTP”, “Fat and Carbs”, “Time to recovery”. I have configured these fields with my user/pw as needed.

Now, when I enter the data screen configuration for this specific screen, the Edge crashes and reboots. Most of the times it’s instance, sometimes (rarely) I can actually get to try replace one of the fields, scroll down to CIQ section, and then crash again.

Just FYI, not sure if the devs are reading this and/or can replicate.

And I vaguely remembered I had this ages ago with a different Garmin. Solution: start an activity (even indoors), allow the data fields to connect same retrieve their data, and then they no longer crash on editing the layout.

Maybe some uninitialised data before first connect to the internet?

I think you’re out of luck for now, as the CIQ fields are not yet compatible with the 1030.

As to the ‘update before the ride’, I have noticed on my 530, that the fields actually update mid-ride as well since on of the latest updates…

(As long as your Edge is connected to your phone and the Garmin Connect app is running)

No, they updated the fields already yesterday, and they are compatible now.

Didn’t know that, sorry. Did you you update the existing fields, or remove and reinstall them and re-authenticate via the Connect app?

You mention scrolling to the settings on your Edge, but I’ve never done that and always used the Connect app. Might be that you can now also configure them directly on the unit though, I haven’t checked…

Hi Iustin,

We’re working with Garmin to get them working properly on the 1030+. We’ll provide updates as they come in. Shouldn’t be too long!


Hi @Cyclopaat - just to clarify, I only installed them once, as they became available. So a single installation.

And by scrolling on the Edge, I mean when selecting the datafields on a given data page inside an activity profile - uh, hard to explain.

For now I’m all set, but I haven’t yet used the fields outdoor.

Hi @ManofSteele, thanks for replying. Note my original problem was solved once I’ve started a (fake) activity and let the fields connects to the internet/retrieve my profile. But I haven’t used them yet outside, so I don’t know if they actually work or not.

Okay, I now understand what you meant - not good if that makes your unit crash, but as Scott said, they’re working on it.

As to the update of fields, just try if they work as I mentioned - if I go to my Xert CIQ data page sometime later on in the ride, the dots go from orange to green. Then again, getting them to update before you leave, is not that bad either.

Once the working fields are available, I strongly recommend removing the existing data fields from profiles, removing them from the device via GCM, rebooting the device, and then trying to perform a fresh install. Still waiting on an update from Garmin at this point… thanks for your patience!

Hello, I finally had time to go for a one hour ride outside. Used the following fields: “What’s my FTP”, “MPA”, and “Time to recover/time to exhaustion”. On a separate page I had the Segment Hunter, but was not used.

Everything went really well, fields synced at the beginning, and worked well during the ride. So all good!