EBC App Breakthrough - But Not in Xert

EBC config question, not a complaint - Today whilst doing a Zwift ride, but using the EBC app to track MPA, I got a breakthrough alert - great, objective achieved. I wasn’t looking for a big breakthough, job done so I eased off (more like collapsed in a heap). I didn’t save the EBC workout, I just use the app to monitor the workout whilst recording data on Zwift, then I discard the workout info from EBC when I stop the workout. Therefore, I don’t have EBC v Zwift workout recordings to compare, but they were both reading power from my Neo trainer.

I look at the Xert analysis afterwards and it’s a ‘near breakthrough’. This isn’t terrible, but it would be good if we could make the EBC breakthrough less likely to announce a breakthrough when it’s a fakethrough.

Is there anything in the EBC app that can be configured to stop such fakethrough alerts and ensure that ‘Breakthrough, you’re a beast’ doesn’t appear until it’s a BT without doubt?


My Garmin said I had a breakthrough but when I uploaded, it wasn’t there. What happened? – Xert (baronbiosys.com)

Same issue with any of the apps. Treat the alert as go harder as long as possible! :slight_smile:

Yeah, I read that.

Is it possibe then to configure the EBC app to just flash the break through, not to keep it on the screen? Or to have it show whilst in breakthrough, but dissapear when not in breakthrough territory?

My issue may have been that the breakthrough message showed on the screen and stayed there… you have to tap to remove it. Tapping the screen wasn’t an option, at the time I was struggling just to breathe.

I suppose they could add a timeout to the alerts if not tapped within, say, 30 seconds?