Doubling of Power in Android App

and… exited 4iii configuration, saw it disabled again, re–enabled. retested and for the moment the numbers match the ANT numbers on my Wahoo Elemnt. Win. thank you Alex!

I have this same issue (power doubling), on both iOS and Android. Tried the ant+ dongle on Android, but that was a disaster. Many drops and spotty connection.

Anyway, it works perfectly on the iPad, except the inaccurate power. Couldn’t find the “enable 3rd party apps” in the 4iii app. Any help would be greatly appreciated.


Btw, power is normal in 4iii app, for Bluetooth.

Tried android again (ant+)…this time using remote player on IPad. Spun for 10 minutes, everything worked perfectly. Activity loaded right up to the server. So far, so good.

Load workout…nothing. No connection to bike whatsoever.

A web search for “enable 3rd party apps in the 4iii app” brings up a link to a Precision Pro manual with doubling mentioned in the troubleshooting section.

Search results also link to similar posts on the TR forum so apparently this is a 4iii anomaly.
The device’s app should include an option to check version and update the firmware.
Perhaps a firmware update will address the issue or at least allow you to enable 3rd party apps.

Thanks your help! I am familiar with the 3rd party fix, but I can’t find the setting. I will take it up with 4iii.

Thanks again,

Well, not sure what or who fixed it, but it’s all set now. iOS app works just fine with bluetooth.