Can't connect my Xert account to Garmin Connect

Hi guys, when I hit the connect button under Garmin Connect option, it goes to garminconnect website and the loading icon keeps turning and turning, and no result. Is it because I am still on trial, or missing something else?

Open a new tab on your browser, go to Garmin Connect, sign out and then sign in again. Once you’ve done that keep that tab open, open up Xert again and repeat the process to connect, it should now work. This is what I had to do after restarting with Xert at the weekend.

1 Like

Thanks mate, this did the trick for me. It was an Authentication error on the Garmin side I suppose. Cheers !

Edit: I thought that would sync all my workouts on Xert to Garmin Connect but it didn’t. Does it only work the other way around as Garmin > Xert? @SecretSquirrel

Yes, you can only sync from Garmin to Xert. If you want to sync a workout to Garmin, you need to record it on a Garmin or in Zwift then it will appear in you activities on Garmin Connect.

That is ridiculous - thanks for pointing that out.

Xert and Garmin Connect currently aren’t talking, so none of my activities have been synced to Xert. I was wondering why my first xert workout was not appearing in Garmin Connect.

Someone on the forum mentioned that might solve this, I will try that.

I use The Breakaway for the best, most graphic power profile - one of the key points for me is that it adjusts after every workout so, like Xert, no need to keep doing tests. However The Breakaway gets its data via Garmin Connect.

I’m on the 30-day trial of Xert (by the way, thanks for that Xert: I just hit the button to sign up preparing to pay and was given a free trial - unexpected!), and this one-way Garmin thing might be a deal-breaker. I am not about to buy a Garmin head unit to solve it.

Garmin Connect no longer accepts data from fitnesssyncer.

Ater an hour or more trying to juggle xert, strava, training peaks and fitnesssyncer (which says it has successfuly synced files but hasn’t)…I discovered on the app that when you open the detailed activity file/report there is an option to “download”. As I’m fast learning with Xert, nothing’s obvious. So this doesn’t mean you’re downloading the report so you can print it out…it actually, halleluja! lets you download the ACTIVITY file as a .fit.
Of course, this means Garmin Connect will happily accept it, and there we are. “Simple”.
No idea why this fix isn’t showing up in any of the support articles or relevant forum posts I’ve been able to access.

A “sync garmin” search should include this hit –
Sync to/from? Garmin Connect - Support - Xert Community Forum (

Lot’s of newbie tips here – Beginner questions - Support - Xert Community Forum (

New YT intro series (more due out in next few months) – Mastering Xert - Discover Your Fitness - YouTube

Xert is a dual device platform. Your phone runs the EBC app. XO ( does the rest in a browser window best experienced on a PC, laptop. or tablet. In combo the two power the Remote Player or Session Player (solo or group sessions).

Welcome aboard. Enjoy the ride.

Thanks for the links.
None of my activities have synced from Garmin Connect. Seems to be a recurring problem. Any current snafus you are aware of?

Well that’s interesting. It took 2.5 days to load 3 (?) months activities with loads of dulplicxates…and apparently I am now “untrained”. Yesterday after 1 ride on xert I had two stars. Ah well.

Do Garmin and Xert hate each other? Rode a Sufferfest workout this morning - Garmin Connect has it instantly. Training Peaks and The Breakaway synced immediately. Xert, linked to Garmiin is telling me 5-6 hours needed - ie 2.5 days. How are we supposed to benefit from the dynamix tech of Xert when there is this amount of delay?

Doesn’t sound like the Garmin sync authorized correctly.
An alternative would be to sync from Strava to Xert if your Garmin activities are on Strava. If that’s the case disable the sync from Garmin Connect.
If there are duplicates something isn’t setup correctly.
If still having issues you can file a support request with:

Hi Simon - saw your note from our support email. Check your email and we can take things from there.


Thanks - yes tried that (disconnecting Garmin and syncing from Strava), So far that hasn’t worked either.

Still puzzled why I am suddenly “untrained” :0)

Thanks Scott, will check