Zwift & Import - Timezone Issue?


When I imported a number of Zwift activities, I noticed a difference in date and time. Example: I had a Zwift session on 2017-11-21 20:45 CET. Xert imports this activity as 2017-11-22 06:45. I had set my timezone in Xert to CET before importing. This only happens with Zwift data, Garmin Edge data is imported correctly.

I tried to import/export the Zwift data via various channels - uploading the fit file from Zwift/activities directly, exporting TCX from Strava, exporting TCX from Golden Cheetah, exporting FIT from Trainingpeaks, etc. - always the same result. However, all the other systems (Trainingpeaks, Garmin Connect, Zwift, Strava, Golden Cheetah) show the correct date & time (2017-11-21 20:45CET).

Any idea how to fix this? Am I correct to assume that this is a cosmetic issue only?


Need to correct myself - Strava shows eerie time data as well. But different from Xert.

Golden Cheetah, Garmin Connect and TrainingPeaks are correct, though.

Since we’re getting the data from Strava or from FIT files (which don’t contain TZ info), we can only speculate based on the TZ from the GPS data. When Strava gets it right or Zwift commit their data directly to us, this will likely get resolved. No ETA yet. :frowning:

Thank you for the update!