Speed 200kph Xert workout garmin connectiq


Trying to do a workout for several days on the garmin edge 530 with the connectiq app but I get crazy speeds. I tried several options listen on the site. Disable sensors. Remove all sensors. I have an elite direto trainer.

On the support site there is mention about the same issue but not really a solution. Couple of days ago it was working normally but now for some reason it down not work anymore.

I have also zwift running where I unpair controllable of the smart trainer. So the garmin must control the trainer.

any thoughts? was there an update perhaps op de connectiq app?

Looks to be an issue with Elite Direto in particular but always best to use Speed from Power –
Unsure if there is a Connect IQ app update since the Connect IQ store is currently down. :slight_smile:


SO i tried again a lot of stuff.

I dont know exactly what but I like to believe the calibrate with the elite did the trick, Also I changed battery on my garmin cadence sensor. I now use that one instead of elite smart trainer cadence

But im still unsure if i need to add the trainer to the indoor profile or not. Do I connect the sensor or not.

I managed to do some a training, no grazy speeds but still some big speed differences in zwift and xert. Too bad, my edge rebooted for some reason. I could not finish the training. :frowning:

those are the same activity

Hi Patrick,

See my response in the other thread.