Issue with MPA Garmin ConnectIQ code. And issue with Xert Mobile.

I can’t update the MPA on Garmin IQ through Garmin Express. the other 3 apps TTE, Fat and carb…etc takes the new Code with no issues except the MPA keep glitching to the default code :(. I tried everything form deleting everything on my GE, phone, Edge 1000 and reinstall over and over again for the last 2 weeks with no luck.

also I did an Xert Moble Workout today “Climber 4X8”, at the last minute of first interval my MPA was below 280 watts and my watts was over 320 for a good 40 seconds and the Xert App Sounded something like “WOW” “YEAH” for my breakthrough but after I looked it on Xert Online under Activities, the breakthough was not in there! it’s kinda disappointed. I did it again on the 2nd interval with at least 30watts over MPA for a good 20s and that one showed on the breakthrough with just a few watts over MPA, but I’ll take it.

There appears to be some ongoing issue with Garmin Express. Some are complaining they can’t update their settings at all. Have you tried using the Garmin Connect mobile app?

Please send us the FIT file. We’ve been working on changes to ensure that the data coming from the ANT+ interface that Xert Mobile evaluates for MPA is that same as what Xert Online is using so that we can eliminate these discrepancies. Send it to

I sent you the file in TCX, couldn’t convert them to FIT. Also I did update my code through GC Mobile App and it went through “THANKS” but I see a Bronze/Gold Medal in the MPA/Power field! also there is some value in the Fat/Carbs field of 33.4g and 161.9g. Cheers.

Shar. We haven’t see the TCX file as of yet. If you could send us the FIT file that will work too. Tap the activity in the Activity Log then tap the three dots on the top right and tap Share. That’s probably the easiest way to email it to us.

Another thing to check is to make sure your signature is being updated. Under Settings you’ll see your signature values. If XM has network connectivity, it should update your signature with your latest. (If you subsequently change it on Xert Online or an activity is uploaded that changes it, then your current signature on XM may be different. )

I just emailed the FIT file, and my Signature on XM is spot on- matching Xertonline, I always check it out after every time I click " Recalculate Fitness Progression"
Thank a million.

FYI … the new Garmin connect took away the three dots “…” button that was used to edit settings. Now in garmin connect app you just right click on the data field and you can select the settings menu from there to change your code.

You can also do it directly from the garmin connect mobile app.

Brian Faulconer, Xert Admin were referring to the 3 dots on Xert Mobile App not Garmin Connect App. Thank you thou.

Hi, Having similar issues on Edge 820 with 5.20 firmware. I reinstalled my Garmin Express on my PC and then the signature code was updated and matched the code on Garmin Connect app for all my downloaded Xert apps. At first all the Xert codes were not matching. Garmin Express kept showing default code and Garmin Connect app was showing my signature code. The main problem I’m having now is that the MPA datafield is defaulted to 1200w and does not reflect my signature MPA from Xertonline. Working with Armando via email to hopefully get a fix.

Yes, it can be frustrating at time! I took of me lots uninstalling/ reinstalling, in all -GE -GIQ and GC Good luck.

Mine worked after uninstalling Garmin Connect app on phone, Garmin Express on PC and factory rest on Edge 820.

I’m having the reverse issue. I can load workouts onto my Edge 520 from Garmin Express on my laptop, but can’t make it work with Garmin Mobile on my Android. Part of the problem is that the process isn’t real clear - it apparently involves Garmin Mobile, xert mobile, xert online and the Edge itself. I’ve gotten everything from the “no connection” message to a purportedly downloaded workout followed immediately by the ciq program shutting down. Even when I have managed to download and start a workout, the ciq player won’t control resistance on my Magnus trainer. In a particularly frustrating session the other night, the player did control my resistance to the extent that it wouldn’t let me go below 160 watts or above 290, which ironically precluded me from executing either my work or recovery intervals. I love the player when it works, which has been exactly twice in the last three weeks. Any suggestions?

Check that you’re not getting interference on your wifi and bluetooth networks. Some users have been reporting that the 2.4ghz band on channel 11 can cause interference and dropouts. Also be sure your battery levels are high as the Garmin will disconnect Bluetooth if battery is low. The Xert Player for CIQ does not need Xert Mobile. They are separate (and should not be run simultaneously). If you are seeing strange trainer behaviour be sure there aren’t any other apps that are attempting to connect to it (for example if you’re doing your workout in Zwift).

Thanks, I’ll check for these issues. One thing I didn’t mention: when the ciq player is playing a workout, I can access the control screen by pushing the return button. However, only the “select” and the “on/off” options appear to work. If I highlight “powermatch” or “resistance” and push the select button, the player simply returns to the workout screen. Is this normal?

No. That’s not the correct behaviour. If you see POWERMATCH is OFF and select that, you should see ON and OFF as selectable. Once selected, it will go back to the recording. Clicking select again, you should then see which value you seleced: POWERMATCH is . If you select POWERMATCH is OFF and it goes straight back to the recording, you may have a faulty select button on the unit as it might be sending two key presses to the app.

I don’t think it’s the button on the unit since it works fine with everything else - including the other two options on the configure screen. Also, I don’t see an “on” or “off” option on either the powermatch or resistance buttons - just the word itself. As I said, when I try to select either of those options the player just returns to the workout screen. For whatever reason, I am able to configure those options from Garmin express on my laptop.

The “return” button opens up the trainer control menu containing the options “POWER CONTROL,” “RESISTANCE,” “OFF,” “SELECT,” and “RECONNECT”. Selecting “POWER CONTROL” during a workout just tells the app to automatically set the trainer target power to match the workout. Selecting “RESISTANCE” switches to manual resistance control - afterwards, using the up and down buttons on the edge520 will set the trainer resistance from 0% to 100%.

The other options menu is accessed with the upper right “select” button on the 520. This menu will have the “POWERMATCH ON/OFF” and other options.

Thanks for the help. Interestingly, I just get the first 4 options with the return key - no “reconnect” option. I’ll see if the select key does the trick. Last (I hope) question - should my power profile update automatically when I load a workout? The player was showing the default profile last night.

The edge 520 only has space on the screen for 4 options, the 5th RECONNECT option might only appear if you scroll all the way down with the arrow keys.

The connectiq workout player should obtain the new peak power, hie, and threshold numbers automatically right before it downloads the currently selected workout. If there is no internet connection, or the garmin edge isn’t connected to a phone running Garmin Connect for android or iOS, the player will just use the profile and workout it got last time. If you select a different workout, does it load on the workout player correctly? If it does, then it should have also downloaded the correct profile.

Well, thought I had this figured out but apparently not. I tried to select a workout this morning using my phone. Opened the Xert app and the Connect IQ app, selected hardness N0. 8 workout and tapped select. xert app indicates workout selected. No notification from GC about logging in to the xert app (which, by the way, I get regardless of whether I’m already logged in.) Selected iq player app on 520 - it shows “HTTP error” then under that “processing workout” When workout opens it shows over/under intervals, which is the last workout I loaded. Tried several times with several variations, i.e. selecting workout with iq player open, iq player closed, etc. No luck. Finally plugged 520 into my laptop, opened xert, selected hardness No. 8 workout and then tried to configure with Garmin Express on laptop. Initially wouldn’t select new workout but finally did after I configured player on GXpress and then hit sync. Finally, player shows H#8 selected. Out to bike, fire up trainer, start workout - Success! H#8 now running - except power output is higher than target, so powermatch not working even though mmenue shows it’s on. No problem, I open menu, hit select and input my trainer Id. Power output drops toward target - and iq player shuts off, giving me the IQ icon with a yellow exclamation point in the middle of it, Back to square one - restart iq player, resend workout, reauthorize through garmin connect. Workout loads, I start it, same problem, same result. I re-start player, which now doesn’t want to load H#8 workout. IQ player finally shows workout loaded, I push enter - Hey, presto, we’re back to over/under workout. I give up on workout I meant to do and decide to just do as much of O/U as I have time left for (not much at this point). Start workout, no powermatch (even though menu shows it’s activated) go to select trainer, input trainer ID, program shuts off again. Should note here that player actually is controlling trainer to some extent, since in 53/11 I was generating 270 watts at 90 rpm - far below what that combination generates when iq player is off. However, there was no change in resistance when the workout power target increased. Tried once more with same result, finally gave up and used the remaining 30 minutes winging it. Any ideas? Do I need to sacrifice a chicken before starting? Rotate counter-clockwise while reciting the opening subtitles from Star Wars? I’m willing to try anything if it results in me actually getting a workout completed with this program.